Autor Zpráva
Majlovic
Profil *
Moderátor Davex: Vytrženo z nesouvisejícího tématu.


Nazdar, s php robím prvý krát takže možno chyba môže byť naozaj banalita.. Stiahol som si Apache, a do .html vlozil <?php include("menu.php"); ?> menu mam vytvorene v php a je tam čisto text ktorý ma byt zobrazený. No fakt rozmýšlal som čo to moze byt ale nejako sa mi to nezobrazuje na webe. Ak máte nejaké rady alebo nápady rád si vypočujem :) dakujem.
Chro
Profil
"... a do .html vlozil..." Musíš to vložit do .php
Majlovic
Profil *
 <header>
<h1>Kontakt</h1>
</header>

<nav>
<?php include("menu.php"); ?>
</nav>

toto je čast html suboru. A ten ktorý vkladám je php. To je zle?
Chro
Profil
Není to zlé. Ovšem oba soubory, jak vkládaný tak do něhož je vkládáno, musí mít přípony .php
Majlovic
Profil *
tak napríklad index.html premenujem na index.php . Ale potom sa mi na stranke zobrazy cely zdroják a nie design webu. Čo s tým? možeš mi tu prosím v skratke vysvetliť ako to spraviť aby to celé frčalo?
Rfilip
Profil
máš na počitači spuštění webový server a php engine?
Majlovic
Profil *
mám spustený apache
Rfilip
Profil
Co máš za OS? Apache jsi stahoval samotný nebo v nějakém balíčku?
Chro
Profil
Problém bude pravděpodobně v instalaci/nastavení Apache. Pro radu nejsem znalostně na úrovni. Založ si prosím vlastní vlákno nebo zkus hledat ve zdejší databázi problémů, zde je nesouvisející problém s include.
Majlovic
Profil *
Apache som stahoval sam , takze zrejem treba este nieco k tomu stiahnut?
Rfilip
Profil
Ano, samozřejmě ještě php engine ale je lepší to stáhnout v jednom balíčku.
Co máš za operační systém?

Od [#5] prosímmm o přesun do nového vlákna

Moderátor Davex: Vyčleněno.
Majlovic
Profil *
Win7, mám
Rfilip
Profil
Osvedčil se mi easyphp.org . Je v tom Apache, php engine a databázový server Mysql(ten se ti bude hodit později.
yFang
Profil
Majlovic:
Přistupuješ ke stránce přes http://localhost/... nebo přes adresu na disku?
Krakatoa
Profil
Rfilip
Mně se zas osvědčil můj balíček :-)
Aktuálně:
Apache 2.4.3 (64bit) + PHP 5.4.9 (64bit) + MySQL 5.5.28 (64bit) + phpMyAdmin 3.5.4 + adminer 3.6.1
http://levtrigo.soft.vserver.cz/

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: