Autor Zpráva
Marpop
Profil *
Jsem zacatecnik s PHP a potreboval bych poradit se spustenim Apache.
Nainstaloval jsem si v praci EasyPHP 1.8. Apache pise ze bezi, ale kdyz zadam
do prohlizece http://localhost nic mi nenabehne a prohlizec pise cekam na
localhost. Doma mi to funguje v pohode

Zkousel jsem i samotny Apache a chovalo se to porad stejne.
Gyoja
Profil *
Zkus tenhle návod:
http://jary.borec.cz/prog/easyphp.php
Jan Tvrdík
Profil
Marpop
Doma mi to funguje v pohode
když ti to funguje doma, tak to tam udělej stejně
nightfish
Profil
není na tom PC puštěný firewall? co je napsáno v logu apache?
Marpop
Profil *
Firewall tady asi bezi na serveru. Ucet mam na serveru, takze se priprihlasovani do Windows neprihlasuji k memu PC, ale na firemni server.
nightfish
Profil
Marpop
v tom případě zeptat administrátora serveru, jestli nejsou nastavena nějaká omezení, která by mohla bránit běhu apache - jenom tak mě napadá, že nemůžeš přijímat spojení na portu nižším než 1024, když aplikace běží pod neprivilegovaným uživatelem (apache běží defaultně na 80)
možná bych zkusil tohle číslo změnit třeba na 8080 a pak otestovat http://localhost:8080/
Marpop
Profil *
Porty jsem zkousel prehodit, ale chova se to porad stejne. S administratorem je tezke, ten Apache ani nevidel. Jinak port 80 mi asi funguje taky, protoze na nem driv valil Skype.
Marpop
Profil *
Jinak v Internet Exploreru mi to píše ve spodní liště otevírání stránky http://localhost/ , ale nic nenabehne, ani nevyhodi chybovou hlasku. Jako by se porad snazil stranku nacist.
nightfish
Profil
v příkazovém řádku spusť netstat -na
a podívej se, zda-li je tam řádek TCP 0.0.0.0:80 0.0.0.0:0 NASLOUCHÁNÍ

jestli ne, apache neposlouchá (neběží)
jestli ano, tak spusť
telnet localhost 80
napiš GET /index.html
a stiskni Enter
když to něco napíše (pravděpodobně nějaký HTML kód), tak server běží a odpovídá na požadavky
Marpop
Profil *
TCP 0.0.0.0:80 0.0.0.0:0 NASLOUCHÁNÍ tam není, ale je tam mimo jine TCP 127.0.0.1:80 0.0.0.0:0 NASLOUCHÁNÍ.
Defaultni adresu má Apache 127.0.0.1
wyny
Profil *
Marpop
Mas natom PC v praci instalovany Skype???
Marpop
Profil *
Jo skype tady nainstalovany mam, ale port 80 je v nem vypnuty.
Marpop
Profil *
Kdyz zadam telnet localhost 80, tak to pise ... Could not open a connection to host on port 80: Connect failed
wyny
Profil *
no tak potom mne problemy robil uz len antivirus NOD kde som v IMON musel dat Apache ako Exlusion a potom vsetko islo bez problemov.... samozrejme bol potrebny restart PC
Marpop
Profil *
Blokoval to NOD 32.
Děkuji všem za rady. Preji krasny den.
Toto téma je uzamčeno. Odpověď nelze zaslat.