Autor Zpráva
anonymus
Profil *
ve Wampu mi neběží <? include "neco.php"; ?> , ale v EasyPHP to běží ...může to být v nějakém nastavení???
děkuji
Měsíček
Profil
<?php include "neco.php"; ?>

EDIT:

Ano, můžeš to změnit - najeď si do souboru php.ini a změň tento řádek short_open_tag = off na on, ale pozor WAMP někdy nechce dát na nastavení php.ini a musíš to nastavit přímo v programu (jinak si to dá zpět sám).
Str4wberry
Profil
Odpovídám anonymusu:
Viz http://diskuse.jakpsatweb.cz/index.php?action=vthread&forum=9&topic=68 712
anonymus
Profil *
Měsíček i Str4wberry
děkuji - pomohlo :-))
peta
Profil
anonymus
mas nastavene, ze nema pouzivat zkracenou syntaxi typu, viz Měsíček
<? prikaz(); ?>
<?=$x?>
cili zbyva uplny zapis
<?php prikaz(); ?>
<?php echo $x; ?>

Urcite bych pouzil uplny zapis, program pak funguje vsude. Na nekterych vecech se nevyplati setrit. Muze se ti stat, ze se dostanes na server, kde ti to admin nepovoli a nepovoli. Protoze php nerozumi a je rad, ze mu to funguje a boji se bezpeznostnich problemu.
Vyhoda vsak je, ze muzes pak napsat <? pro XML, ale i to bych radeji vypisoval pres echo '\<\?' , plus minus nejake lomitko, pro jistotu.
Str4wberry
Profil
Odpovídám petovi:
Kdyby sis klikl na odkaz, který jsem sem vložil, skoro bys ušetřil příspěvek.

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: