21. září bude sraz! Od 18.00 v restauraci Tradice v Praze u Anděla
Autor Zpráva
sabre
Profil
Mam nastaveny Apache 1.3.33, ktory mi zahadnym sposobom ignoruje subory.htaccess cim mi vobec nefunguje mod_rewrite.
Najprv nesiel vobec (mod_rewrite) a kamarat mi poradil nech v .htaccess urobim preklep ci mi server vypise chybu a server chybu nevypisal. Skusal som nastavit konfig od znovu (asi 6 krat) ale ani raz sa mi to nepodarilo spustit... Neviete mi niekto poradit co s tym?
Hugo
Profil
Musis v httpd.conf nastavit AllowOverride na All (nebo jinou hodnotu, podle toho co potrebujes) a potom restartovat apache.
sabre
Profil
praveze to som urobil ako prve..ba dokonca aj apache som restartoval...
Hugo
Profil
A mas dobre nastaveny nazev souboru v direktive AccessFileName??

Jinak to nastaveni je potreba udelat i u virtual hostu (pokud je pouzivas)
sabre
Profil
nazov suou v AccessFileName mam htaccess a ten aj pouzivam v zlozkach... U virtual hostu to nemam nastavene, pokial viem nepouzivam ho.
Hugo
Profil
A mas to zkompilovane s podporou .htaccess??
sabre
Profil
teraz som ta trochu neporozumel, ale tu je link na ten config (http://files.elepha.info/httpd/httpd.conf) Vsetko by malo byt nastavene spravne.
Hugo
Profil
AccessFileName htaccess

Musis tam mit
AccessFileName .htaccess
sabre
Profil
praveze nie... kamos to ma rozbehane ako -htaccess. AccessFileName urcuje ako sa bude volat dotycny subor... To by ani tak nevadlio iba ono nefunguje ani ked tam mam AccessFileName .htaccess :(
Yuhů
Profil
hoď někam na web svůj httpd.conf, tohle je hádání z letu ptáků

jinak ještě zkus restart apache dělat trochu brutálněji, to jest stop a start, ne pouze restart. U verze 1.3 se mi stávalo, že při obyčejném restartu občas některé věci z konfiguráku nevzal.
Hugo
Profil
httpd.conf je na adrese http://files.elepha.info/httpd/httpd.conf (viz prispevek z 11:26).
Yuhů
Profil
ten .htaccess má být určitě s tečkou, ale jinak nevím, vypadá to, že to je v pořádku.
sabre
Profil
no mal by byt s bodkou ale nemusi... V AccessFileName si mozes nakonfigurovat aky subor ma v zlozke hladat... ak ho nazves yuhuuuconfig tak bude hladat taky subor... Neviem co s tym moze byt... Raz sa mi to podarilo rozbehat (na vojom kompe) ako _htaccess a fungovalo to... potom zrazu o 3 tyzdne z nicoho nic prestalo (konfig som nemenil) a teraz to nejde vobec :((( a nejde to ani ked tam dam povodny konfig... Proste je to ignoracia ako svina :((
Toto téma je uzamčeno. Odpověď nelze zaslat.

0