Autor Zpráva
ajinek
Profil *
čaute, mám porblém :-(

dělám stránky v mozile je to good v IE taky začal jsem dělat admina a admin mi v IE nic nepřidává ani neupravuje :-/ jen když dám smazat tak smaže. V mozile to vše fičí ten admin. Nevíte čím toje ?

Muže to být i tím že ten formulář není zapsán validně? : - / já totiž admina nekontroluju jeslti je valid nebo ne.
Dero
Profil
Pověz mi, opravdu si myslíš, že Ti někdo s tímto dotazem poradí? Vždyť ten nemohl být víc obecnější, nevíme vůbec nic, takže to buď rozveď a detailně popiš svůj problém, nebo odpověď nečekej.
ajinek
Profil *
tak já myslel třeba jestli se to už někomu nestalo nebo tak : - / jak to mám váíce rozvézt? v mozile vše jede a v IE když vypíšu formulář a dám přidat článek tak mi to nepřidá bud jen problikne na cílovou www(action) nebo zustane vyplněne tak jak to uživatel vyplnil. nehlásí to chybu nic jen to nezapíše. v mozile to jede vše, mi to příjde jak by formulář nejel pod tím IE zkusím stím něoc udělat když tak se navás nějak podrobněji obratim no : - /
grafical
Profil
a co takto script ? :/
ajinek
Profil *
vubec nevim nejdemito :-/ v IE to nefiči formulář zustane vyplněný jen tak stát a v mozile mi to odešle a zapíše do DB tak jak má, myslim že to je ve formuláři nebo v čem jiném? : - / tu máte zdroják...

...

echo "Pøidat.";
echo "<form action='a_edit.php' method='post'>\n";
echo "<span class=\"b\">Název kolekce:</span> <input name='jmeno_' size='40' />
echo "<button type='submit' name='add_' value='add'>Pøidat kolekci</button>\n</form>\n";

....

diky za rady
ajinek
Profil *
:-(
Martin
Profil
Zkus začít od začátku, v čem je tedy problém? Můžeš sem dát odkaz na stránku, kde uvedené potíže vyskytují?
Sice nevím v čem je problém, ale zkus
echo "<button type='submit' name='add_' value='add'>Pøidat kolekci</button>\n</form>\n";
zaměnit za
echo "<input type='submit' name='add_' value='add'>Pøidat kolekci</input>\n</form>\n";
ajinek
Profil *
já taky neví mjaký je problém ve zdrojaku jen je problém stím že v mozile to jede vše mi to v administraci přidá a když to otevřu v IE tak mi to nepřidá formulář se jakoby neodešle :- / zkusím to zaměnit
Chamurappi
Profil
Reaguji na ajinka:
Muže to být i tím že ten formulář není zapsán validně?
Ne. Samotná nevalidita ovlivňuje pouze validátory, nikdy prohlížeče. Může jít o problém, jehož důsledkem je chybná interpretace prohlížečem nebo nevalidita nebo obojí. Samotná validita je zbytečná.

v mozile vše jede a v IE když vypíšu formulář a dám přidat článek tak mi to nepřidá
Předpokládám, že problém bude v tom, že Explorer posílá obsah elementu <button>, ne jeho atribut value. Již zde o tom byla řeč.


Reaguji na Martina:
Element <input> je možným řešením, ale dát na jeho tlačítko text tímto způsobem pochopitelně nejde. Zobrazuje se jeho value, obsah nemá povolený žádný. Jeho koncová značka je volitelná a jelikož jde o prázdný element, je i zakázaná.
Toto téma je uzamčeno. Odpověď nelze zaslat.