Autor Zpráva
nevimsirady
Profil *
Ahoj,
nainstaloval jsem si drupal v základním rozšíření. Ze zvědavosti jsem jej zkusil zvalidovat. A ejhle validátor w3c na mě hodil 2 chyby.. Jak je to možné? Myslel jsem že základní šablonu Drupalu je validní?
Chamurappi
Profil
Reaguji na nevimsirady:
A ejhle validátor w3c na mě hodil 2 chyby
Protože používají XML syntaxi v HTML.

Jak je to možné?
Proč by měl být validní?

Myslel jsem že základní šablonu Drupalu je validní?
Asi myslel. Na takovou otázku se těžko odpovídá.
H13
Profil
nevimsirady
Podívej se do validátoru o jaké chyby jde. Je možné, že autor upřednostnil milióny uživatelů před jedním strojem nazývaným validátor. :-)
nevimsirady
Profil *
Mrkni na Odkaz
Joker
Profil
nevimsirady
To ovšem není validátor W3C, ale Chamurappiho validátor (pochybuju, že autor té výchozí šablony pro Drupal vůbec umí česky, natož aby o tom validátoru věděl a validoval v něm).
Validátor W3C hodí zelenou.
Chamurappi
Profil
Neměl by někdo chuť vyrobit plugin, který zařídí, aby z Drupalu lezl validní kód? Měl bych, kam posílat ztracené duše z validátoru. (Podobně jako už mám u Wordpressu.)


Reaguji na H13:
Autor upřednostil používání XML syntaxe psané pro jeden vadný stroj nazývaný W3C Validátor před používáním syntaxe, která je optimální pro milióny uživatelů. Tlak na změnu je asi zatím příliš malý.


Reaguji na Jokera:
Validátor W3C hodí zelenou.
Protože nedodržuje přání autorů XHTML.

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: