Autor Zpráva
motorcb
Profil
Zdravim,

přes composer stahuji Nette:

    "require": {
        "php": ">= 5.3.0",
        "nette/nette": "@dev"
    },

Jenomže nyní se v Nette 2.1dev udály velké změny s /Nette/database a mne se tyto změny stáhly a nefunguje projekt - bude potřeba ho přepsat. OK, ale nyní potřebuji opravit jednu chybu a až bude čas, udělám svůj projekt kompatibilní s úpravami v Nette/Database.

Chtěl bych stáhnout dev verzi před aplikováním techto změn. Jde to?
preca1
Profil
Zdravim,
nikdy sem Composer nepoužíval, ale řek bych, že místo @dev napíšeš konkrétní verzi, kterou chceš.
Jan Tvrdík
Profil
motorcb:
Chtěl bych stáhnout dev verzi před aplikováním techto změn. Jde to?
Ano, víš která verze tam byla před tím?
motorcb
Profil
Jan Tvrdík:
Ano, například bych se chtěl vrátot k této verzi: https://github.com/nette/nette/commit/5a47534e106a40f00306acc3ae56628ac9e0b4f6
Jan Tvrdík
Profil
motorcb:
Buď můžeš zkusit aktuální release candidate připravované verze 2.1.0 (doporučeno)

{
    "require": {
        "php": ">= 5.3.0",
        "nette/nette": "2.1.*@rc"
    }
}

nebo můžeš natvrdo vynutit ten konkrétní commit (nedoporučeno)


{
    "require": {
        "php": ">= 5.3.0",
        "nette/nette": "dev-master#5a47534e106a40f00306acc3ae56628ac9e0b4f6"
    }
}
motorcb
Profil
Tak se moc nezadařilo.
Pokusil jsem se stáhnout verzi:

{
    "require": {
        "php": ">= 5.3.0",
        "nette/nette": "dev-master#5a47534e106a40f00306acc3ae56628ac9e0b4f6"
    }
}

a mám tuto chybu:
composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for nette/nette dev-master#5a47534e106a40f00306acc3ae56628ac9e0b4f6 -> satisfiable by nette/nette[dev-master].
    - nette/nette dev-master requires nette/application @dev -> no matching package found.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.

Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.

Jak z toho ven abych mohl použít verzi #5a47534e106a40f00306acc3ae56628ac9e0b4f6?
Jan Tvrdík
Profil
Jak z toho ven abych mohl použít verzi #5a47534e106a40f00306acc3ae56628ac9e0b4f6?
Si v kelu, varoval jsem tě, že to není doporučený postup. Závislost na konkrétním commitu je hack, který nefunguje vždy. Fungovalo to v době, kdy jsem to psal, už to nefunguje, protože David vydal 2.2, která mění závislosti.

Vaše odpověď

Mohlo by se hodit

Pokuste se již v titulku uvést název programu související s tématem.

Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: