Autor Zpráva
radekt
Profil
Po upgradu Node.js z verze - myslím, že to bylo 0.12.4 - na 5.1.1 mě trápí npm. Měl jsem nainstalováno pár lokálních balíčků (gulp-cssnext, gulp-cssmin, gulp-imagemin...). Když jsem si dříve chtěl nainstalovat další balíček, nainstaloval se jenom ten. Zato teď jsem chtěl doinstalovat gulp-uglify a nainstalovalo se mi dalších cca 130 balíčků. Když ty nepotřebné smažu, Gulp se nepustí, zahlásí, že nějaký chybí, tak jej nainstaluji a jsem zpátky, kde jsem byl předtím, mám tam zase nějakých 130 balíčků. Pravdou je, že Gulp pak funguje, ale proč tam v této verzi toho npm cpe tolik?
Kubo2
Profil
Nie sú to závislosti gulp-uglify a ich závislosti?
radekt
Profil
Kubo2:
Troufám si odhadnout, že ne, na to je těch balíků moc a podle názvů jsou na vše možné. S gulp-cssmin, což je podobná úloha, se mi ve staré verzi žádné závislosti neinstalovaly.


Ještě doplňuji - instalace verze 5.1.1. neproběhla standardně. Na konci procesu instalátor nahlásil "Node.js Setup Wizard ended prematurely". Pak provedl rolling back, takže co se nového natáhlo, to se odinstalovalo, bohužel starou verzi to stačilo zrušit také. Takže jsem se vrátil pomocí bodu obnovy ke staré verzi. Vygooglil jsem několik metod, jak to obejít, jediná, která mi fungovala, je vymazat obsah C:\Program Files\nodejs a pak tam pomocí utility lessmsi ručně zkopírovat rozbalený instalační msi soubor.

Vaše odpověď

Mohlo by se hodit

Pokuste se již v titulku uvést název programu související s tématem.

Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: