Autor Zpráva
marek1985x
Profil *
ahoj,

měl bych dotaz na Excel...

mám několik desítek řádků s čísly v 30 sloupcích.

Potřebuji pro každý řádek dostat součet 12 nejvyšších hodnot (z těch třiceti)

Napadá někoho nějaký vzorec?

díky moc
Axamith
Profil
Přímo X nejvyšších hodnoz z Y čísel nejspíše nedosáhneš, ale mohlo by ti pomocí řazení podle hodnoty, buď vzestupně nebo sestupně. Pročti si v nápovědě příkaz RANK
Mastodont
Profil
Dá se to řešit maticovým vzorcem. Udělej si pomocnou oblast s čísly 1 až 12, z níž použiješ jednotlivé buňky jako parametr funkce LARGE.
Dejme tomu, že tato čísla máš v oblasti D1:D12, pro oblast A1:30 pak součet 12 nejvyšších čísel dostaneš maticovým vzorcem
{=SUMA(LARGE(A1:A30;D1:D12))}

Ty složené závorky se tam nepíšou ručně, ale přes Ctrl+Shift+Enter.
marek1985x
Profil *
díky moc, jseš bůh :)

Vaše odpověď

Mohlo by se hodit

Zvažte, zda se neobrátit na specializované fórum, toto se zabývá především webovou problematikou.

Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: