Autor Zpráva
stanavaf
Profil
Ahoj, mám takový problém, pro někoho asi naprosto primitivní, ale potřebuji do buňky zapsat vzorec. Jaký? Uvedu o co mně vlastně jde: řekněme, že v buňce A1 je číslo (s jedním desetinným místem), které se zapisuje na základě vzorce (to je jedno, třeba = SUMA ...) a já bych potřebovala, aby se mně v buňce např. B1 zobrazoval text "NEPŘIJAT" v případě, že to číslo bude v rozmezí od 0 do 0,9. Současně, aby se v buňce B1 zobrazoval text "NEPŘIJAT" v případě, že číslo bude větší než 2. V případě, že by bylo číslo v rozmezí od 1 do 2 (a to v četně těchto čísel), aby se zobrazovalo "PŘIJAT". Myslím si, že by to mohlo jít nějak přes funkci =KDYŽ, ale nemůžu přijít na to, jak to zapsat. Blbá, co.
Díky za veškeré rady. Pa St.
Joker
Profil
Co to má společného s webem?

=KDYŽ(A1>=1;KDYŽ(A1<=2;"PŘIJAT";"NEPŘIJAT");"NEPŘIJAT")

edit: upravil jsem vzorec, takhle snad lépe odpovídá zadání
Mastodont
Profil
=KDYŽ(A(A1>=1;A1<=2);"PŘIJAT";KDYŽ(NEBO(USEKNOUT(A1)=0;A1>2);"NEPŘIJAT ";""));
stanavaf
Profil
Omlouvám se, vložila jsem otázku do špatného témata diskuse. Bylo-li by to možné, prosím admina, zda-li by nemohl otázku přesunout do témata: Práce s počítačem, tam už otázku na Excel 2007 někdo vložil a zřejmě to nikomu nevadilo.
Děkuji za odpovědi. St.
peta
Profil
Joker
kde je napsano, ze jak neco udelat ma neco spolecne s webem?
Ja myslim, ze tema je naprosto spravne a tema Práce s počítačem spis povazuji za prezitek, kde to stejne napise malo lidi.

stanavaf
to od Jokera by melo urcite fungovat
KDYŽ(A1>=1;KDYŽ(A1<=2;"PŘIJAT";"NEPŘIJAT");"NEPŘIJAT")
Zkusil bych mozna
KDYŽ(A1>=1 AND A1<=2;"PŘIJAT";"NEPŘIJAT")

Mastodontuv zapis mi prijde hodne podivny, mozna, ze by se to dalo prave zapsat jako:
KDYŽ(A(A1>=1;A1<=2);"PŘIJAT";"NEPŘIJAT")
na druhou stranu, muze vyjadrovat presnou podminku. Cili od A do B a od C do D, jinak E. Cili, kdyz se tam objevi chyba typu -1.5 , tak se nezobrazi chybne NEPRIJAT. Protoze, jak znam neduslednost sekretarek, tak jsou schopny tuto chybu prehlednout.
vonv
Profil
stanavaf
Pro tyto potřeby je taky funkční příkaz svyhledat - používá se pro práci právě s nějakými intervaly. Pro tvoje potřeby určitě stačí už zde uvedené jednodušší vzorce, ale pro práci s daty do budoucna je příkaz svyhledat poměrně užitečný až nezbytný. Popis jak se tento příkaz používá a hlavně spoustu tutoriálů na excell najdeš tady: http://www.dataspectrum.cz/pages/glossary/glossary.htm
a konkrétní popis příkazu svyhledat je tady (zazipovaný word): http://www.dataspectrum.cz/excelmag/download/eam0403w.zip
Joker
Profil
peta
kde je napsano, ze jak neco udelat ma neco spolecne s webem?
No, na "diskuse.Jak psát web.cz, diskusní fórum o webdesignu" bych to skoro očekával

Zkusil bych mozna
KDYŽ(A1>=1 AND A1<=2;"PŘIJAT";"NEPŘIJAT")

Výsledkem toho je "Zadaný vzorec obsahuje chybu"
Mastodont
Profil
Já jsem se držel zadání, kde jsou brána do úvahy jen kladná čísla + nula, čili pro záporná čísla vzorec nezobrazí nic.
stanavaf
Profil
vonv
Ty stránky Tebou zadaný : nejdou mně načíst.
Bubák
Profil
www.dataspectrum.cz/pages/glossary/glossary.htm
www.dataspectrum.cz/excelmag/download/eam0403w.zip
Text je dobře, ale odkazy jsou špatně.

Vaše odpověď

Mohlo by se hodit

Zvažte, zda se neobrátit na specializované fórum, toto se zabývá především webovou problematikou.

Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm:

0