Autor Zpráva
Keeehi
Profil
Šlo by někam do nastavení přidat možnost tuto funkcionalitu vypnout? Vůbec mi nevyhovuje a řekl bych, že nejsem sám. U dost příspěvků se [/pre] objevuje na konci. Už se mi to také povedlo a mohlo za to právě to automatické doplňování.

Případně bych prosil odnavigovat tam kde je ta funkcionalita v JS implementována a já už si to znefunkčním.
Str4wberry
Profil
Úplně přesně nerozumím popsanému problému s [pre]. Co já pozoruji, tak je problém, když někdo vloží obyčejný text spolu s kódem, tak se obalí všechno. Ale už je na to automatické obalení alespoň člověk upozorněn.
Chamurappi
Profil
Reaguji na Keeehiho:
U dost příspěvků se [/pre] objevuje na konci.
Také jsem si dnes uvědomil, že to vídám hodně často (zkusil jsem si hledat [/pre]). Chybička se vloudila, za kód, který už je obalený do [pre], by se nemělo přidávat další uzavírací [/pre]. Jsou problémy jen s tímto, ne? Nebylo by lepší žádat o opravu téhle chyby, než o vypínač celé funkce?
Keeehi
Profil
Mně to prostě nevyhovuje. Stejně jako některé automatické opravy které mi nutí word, ovšem tam jsem si to právě mohl vypnout. Ale byla tu další věc, co mě nevyhovuje, avšak asi se s tím nedá nic dělat, protože je to regulérní chování. Stalo se mi, že jsem psal nějaký kód a neměl ho obalený v pre, jelikož to dělám většinou těsně před odesláním příspěvku. Pak jsem si potřeboval něco do prostředka toho kódu, tak jsem to okopíroval a vložil. Automaticky se mi to obalilo a to jsem právě vůbec nepotřeboval. Než jsem si toho přidávání všiml, vložil jsem to i na jiná místa a pak jsem to musel zase všude odmazávat.
Str4wberry
Profil
Automaticky se mi to obalilo

A to je nějaký problém? Pokud potom obalíš celý blok, tak se ta vnitřní [pre] vyhážou a vše je jak má být, ne?
Keeehi
Profil
Str4wberry:
Pokud potom obalíš celý blok, tak se ta vnitřní [pre] vyhážou a vše je jak má být, ne?
Kdybych to věděl tak ano. Jelikož jsem to neočekával tak jsem to ani nezkoušel.
Chamurappi
Profil
Reaguji na sebe:
Chybička se vloudila, za kód, který už je obalený do [pre], by se nemělo přidávat další uzavírací [/pre].
Opraveno.
Teď by to chtělo globálně nahradit všechny </pre></div>[/pre] za </pre></div> v příspěvcích poslaných během posledního měsíce (je jich přibližně 36).


Reaguji na Keeehiho:
Uvažoval jsem, že bych upravil automatiku tak, aby se vypnula po prvním uživatelsky vyvolaném obalení do [pre] (tedy po stisku tlačítka či Ctrl+E) až do okamžiku opuštění stránky. Ale to by ti stejně asi nevyhovovalo, protože obaluješ až těsně před odesláním příspěvku…
Kajman
Profil
Chamurappi:
(je jich přibližně 36)
V 32 příspěvcích jsem to nahradil (prováděl jsem to jen pro post_id>880000).
Keeehi
Profil
Chamurappi:
No už jsem si na to trochu zvykl i když se to občas pořád chová nelogicky.
Str4wberry
Profil
Můžeš uvést příklady nelogických chování? Takhle se z toho dá těžko udělat nějaký závěr.
Keeehi
Profil
Str4wberry:
Konkrétní příklady uvést nemohu. Vím že se mi to stávalo (ale jen občas) když jsem kopíroval jeden řádek. Nevím, jestli to má být ošetřené, ale dělalo to i v případě, že už jsem měl nějaký blok do pre obalený. Přesto mi to ten jeden řádek ještě obalilo. Ale pravidelnost jsem v tom žádnou nezpozoroval.

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: