Autor Zpráva
M.F.
Profil *
Prosim pomozte mi s mojim problemom. Chcem aby sa mi objavovala ikona icq vo flashi. Mam flash 8 a postupoval som takto:
Vytvoril som si prazdne movie do ktore sa mi mala nacitat ikona. Action script som pouzil takto:

OnClipEvent (load) {
loadMovie("http://status.icq.com/online.gif?icq=285010466&img=5", "", "POST");
}


Po spusteni flashu sa zobrazi pradna biela plocha a ikona sa nenacita....
Neviete mi povedat kde mam chybu, pripadne co som spravil zle?
M.F.
Profil *
No ikona uz funguje, ale v samostatnom movie...problem je v tom, ze ked ju chcem nahrat do levelu 2, tak sa nechce zobrazovat...pomoze mi niekto?
Zephy
Profil
Pro nahrati do urciteho levlu musis pouzit misto "loadMovie" prikaz "loadMovieNum":


loadMovieNum("http://status.icq.com/online.gif?icq=285010466&img=5",2) ;


Me takto na druhem levlu krasne sviti ;o)
M.F.
Profil *
Dakujem uz to ako tak funguje, ale mam dalsi problem...mam to spravene tak, ze ked ukazes na tlacitko tak by sa mala ukazat ikona icq....a ked das kurzor z tlacitka prec, tak ikona zmizne...problem je v tom, ze mne robi presny opak. Ked dam kurzor na tlacitko, tak sa nedeje nic (ale mam pocit, ze sa da pokyn k nahravaniu ikony) a ikonu spusti az ked dam kurzor prec....no a co mam robit teraz? hm?
M.F.
Profil *
No uz som vyriesil aj to :-) , ale posledny problem je ten, ze by som chcel niekam tu ikonu umiestnit...ako zadam suradnice aby som dal tu ikonu na urcite miesto?
Zephy
Profil
Nahrat ji do movie clipu a pak klasicky urcit souradnice jmeno_mc._x a jmeno_mc._y
...ale to uz sis asi taky vyresil :-)
M.F.
Profil *
Prosim pomoz mi.... napisal som nasledovny kod a stale sa mi ikona zobrazuje v pravom hornom rohu...

_root.createEmptyMovieClip("icq_mc",1);
_root.icq_mc.loadMovie("http://status.icq.com/online.gif?icq=285010466 &img=5","","POST");
setProperty("icq_mc", _x, 640);
setProperty("icq_mc", _y, 660);

Kde mozem mat chybu? Uz som z toho zufaly...please help!
M.F.
Profil *
no super ze mi kazdy odpisuje...
Zephy
Profil
mno ja si nemuzu pomoct, ale kdyz jsem ten skript zkopiroval presne jak je tu uveden do "Layer 1:1" uplne prazdneho flash dokumentu, tak je ikonka vpravo dole a tam ma byt ne?
tezko potom radit. asi bude problem v umisteni uvedeneho skriptu, nebo to jenom nemas refreshnuty.
Scenu jsem mel 750x740, proto neni uplne u kraje:
Toto téma je uzamčeno. Odpověď nelze zaslat.