Autor Zpráva
Pája
Profil *
Dobrý den,
implikoval jsem na nový server Joomlu, ale ukazuje to tohle. Kde je problém?

Warning: require_once(/www/includes/version.php) [function.require-once]: failed to open stream: No such file or directory in /data/web/virtuals/4704/virtual/www/includes/joomla.php on line 71

Fatal error: require_once() [function.require]: Failed opening required '/www/includes/version.php' (include_path='.:/data/web/virtuals/4704/virtual') in /data/web/virtuals/4704/virtual/www/includes/joomla.php on line 71
Pája
Profil *
Pokud se to pokusim nainstalovat znovu, tak mi to ukaze po otevreni INSTALL.php Restricted access a nevím si s tím rady :(
karel_
Profil *
/www/includes/version.php
- existuje takový soubor na FTP?
Pája
Profil *
ano. version.php v includes je.
mozna bez toho www?
Pája
Profil *
Kdo by byl schopný to rozchodit a za cenu? Díky
H13
Profil
Ahoj, jakou používáš verzi systému Joomla!

Ani Joomla! 1.5.22, ani 1.6.1 neobsahují version.php v includes složce.

1.5.22 obsahuje joomla.php, ale ten má 7 řádků a žádný version.php nenahrává

?
Pája
Profil *
Delam to pro znameno. Presel na novy hosting.
Rekl bych, ze nejspis Joomla 1.0.11
Ale uplne jiste to nevim.
H13
Profil
Rekl bych, ze nejspis Joomla 1.0.11
Tak to jsi o pár let pozadu, nainstaluj nejnovější 1.5 verzi (1.5.22) nebo 1.6 (1.6.1)
Pája
Profil *
Pokousel jsem se tedy nainstalovat novejsi 1.5, ale zadrhel nastal pri vytvoreni tabulek do db.

hodi to chybu:
You have an error in your SQL syntax; check the manual that corresponds to your MySQL serve.......

:(
H13
Profil
Pája
You have an error in your SQL syntax; check the manual that corresponds to your MySQL serve.......

No chtělo by to, aby jsi sem uvedl celou zprávu, a ne jen všeobecný začátek (to je jako kdyby jsi chtěl reklamovat auto, ale nedovezl by jsi ho do autosalonu ukázat - "auto je rozbitý, ale neukážu vám ho" :-) )
Pája
Profil *
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'TYPE=MyISAM CHARACTER SET `utf8`' at line 29 SQL=CREATE TABLE `jos_banner` ( `bid` int(11) NOT NULL auto_increment, `cid` int(11) NOT NULL default '0', `type` varchar(30) NOT NULL default 'banner', `name` varchar(255) NOT NULL default '', `alias` varchar(255) NOT NULL default '', `imptotal` int(11) NOT NULL default '0', `impmade` int(11) NOT NULL default '0', `clicks` int(11) NOT NULL default '0', `imageurl` varchar(100) NOT NULL default '', `clickurl` varchar(200) NOT NULL default '', `date` datetime default NULL, `showBanner` tinyint(1) NOT NULL default '0', `checked_out` tinyint(1) NOT NULL default '0', `checked_out_time` datetime NOT NULL default '0000-00-00 00:00:00', `editor` varchar(50) default NULL, `custombannercode` text, `catid` INTEGER UNSIGNED NOT NULL DEFAULT 0, `description` TEXT NOT NULL DEFAULT '', `sticky` TINYINT(1) UNSIGNED NOT NULL DEFAULT 0, `ordering` INTEGER NOT NULL DEFAULT 0, `publish_up` datetime NOT NULL default '0000-00-00 00:00:00', `publish_down` datetime NOT NULL default '0000-00-00 00:00:00', `tags` TEXT NOT NULL DEFAULT '', `params` TEXT NOT NULL DEFAULT '', PRIMARY KEY (`bid`), KEY `viewbanner` (`showBanner`), INDEX `idx_banner_catid`(`catid`) ) TYPE=MyISAM CHARACTER SET `utf8`
H13
Profil
Pája

Tak teď budu jen tipovat (protože neznám tvý běhový prostředí)

Tipnul bych, že máš nejnovější verzi mysql, která nepracuje s "TYPE" ale používá "ENGINE"

Pokud ano, pak jsou dvě možnosti, downgradovat verzi mysql, nebo přepsat všechny "TYPE" na "ENGINE" v databázových dotazech (v Joomle!)
Pája
Profil *
Dekuji. Bylo to opravdu tim.
Nakonec se mi povedlo rozchodit tu sterou verzi.

http://www.autobazarforis.cz/index.php?option=com_content&task=view&id=16&Itemid=31

Jen nefunguji sekce. Muze byt jen spatna chyba v configuration.php? Nebo se jedna o slozitejsi chybu?
Co byste mi poradili? Kdyz tam aplikuji Joomlu 1.5, tak nevim jak prenesu ten design + celkove obsah. Hlavne aby to sedelo.
H13
Profil
Pája
No asi bych ten web postavil znovu na 1.5 nebo 1.6, rozhodně bych nepoužíval starou verzi (ať už z bezpečnostního hlediska nebo z hlediska dostupnosti rozšíření)
rorsach
Profil
Můžeš to buď převést sám, nebo použít instalátor (JoomlaPack- Akeeba). Na tarém webu, commáš pod 1.0 bys měl spustit JoomlaPack 1.1.1 nebo 1.2a2. Sám jsem tu verzi nenašel.
Zde je ale JoomlaPack 1.1.1b, což je sice betaverze, ale mohla by být stabilní.
- Po úspěšné migraci z 1.0- 1.5 již není co řešit. Příp. je možné provést transfer na 1.6. V tom případě řešit Akeebou.

Pokud chceš dej mi vědět. Mohu ti to kompletně zkusit nanečisto na svém serveru, aby jsi neriskoval ztrátu dat. Dej mi vědět kdyžtak na email email"zavinac"kallados.com

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: