Autor Zpráva
maestorm
Profil
Zdravím, podařilo se mi rozjet wordpress na webzdarma.cz, jen jsem se dostal do fáze, kdy se mi daří nahrávat soubory a zobrazují se mi v administrativě pod záložkou media->library. Problém mám však s přiřazováním nahraných obrázků a zobrazováním jak v administrativě po nahrání přes rozhraní WordPressu, tak na webu jako takovém. Nemyslím si, že by se jednalo o nevyřešitelný problém, proto vás žádám o radu/pomoc jak tuto drobnost napravit? Zkoušel jsem již deaktivovat pluginy, změnit oprávnění složek rekurzivně na 755 a také jsem kontroval přes ftp, zda-li se obrázky, které nahraji uploadují, což funguje. Zároveň bych dodal, že v administrativě se mi hned pod horní lištou zobrazuje chybová hláška:
„Warning: glob() has been disabled for security reasons in /3w/wz.cz/a/atelier/wordpress/wp-includes/l10n.php on line 858“.

Děkuji za možnou pomoc.
Tomáš
smitka
Profil
Webzdarma není úplně vhodný hosting pro WP. Je zde velké množství omezení (např. právě zakázaná funkce glob()). Problémy s uploadem souborů také budou souviset s nějakým omezením/špatnými právy.

Každopádně WZ mají 2 servery - starý Jupiter a novější Venuše, kde není tolik omezení a WP by tam měl fungovat vcelku dobře. Podle chyby budete pravděpodobně na tom starším.

Osobně bych zvolil normální hosting, nebo přešel například na wordpress.com.
noko
Profil
Na jeké doméně druhého řádu máš web? Já .wz a web je na na serveru Venuše, takže možná to jakou si vybereš doménu druhého řádu souvisí s tím jaký ti přiřadí server.
maestorm
Profil
Doménu mám na wz.cz našel jsem wordpress.org/support/view/plugin-reviews/hotfix na glob(). Ale stále mám zatím problém s těmi nahranými obrázky.
Kohol
Profil
maestorm:
Ahoj, můžu se zeptat, jak se ti podařilo vyřešit na webzdarma ten glob() ? Stáhnul jsem a aktivoval uvedený plugin Hotfix, ale chybu to pořád ukazuje...
Davex
Profil
Kohol:
Jak psal smitka, tak Webzdarma má víc serverů a Wordpress by měl fungovat na tom novějším (Venuše), kde je i novější verze PHP. Pokud tam máš web déle jak rok a půl (založený do března 2015), tak je pravděpodobné, že je na starším serveru, kde to fungovat nebude.

Zdá se, že plugin Hotfix řešil nějaké dílčí problémy historických verzí Wordpressu do 3.5 kolem roku 2012, takže dnes bych ho rozhodně nepoužíval.

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: