Autor Zpráva
Peett
Profil *
Dobrý den, otázka je jasná. Chtěl bych pro práci s databází používat rozšíření PECL PDO, ale můj server ho nepodporuje. Jak ho tam tedy přidat? Našel jsem tyto stránky http://pecl.php.net/package/PDO ale nevím jak mám dále postupovat, Děkuji
Peett
Profil *
Můžete mi pls někdo poradit?
Mastodont
Profil
No jestli to není tvůj server, tak není s čím radit, PECL balík může instalovat správce serveru. PDO je součástí PHP od verze 5.1, tam není třeba nic instalovat.
Peett
Profil *
Hmm to je divny, ja mam verzi 5.2.6, ale po vypsani phpinfo() tam zadne PDO nemam.
Peett
Profil *
Po zavolani teto funkce
print_r(pdo_drivers());
mi vyjede chyba Fatal error: Call to undefined function pdo_drivers()
Davex
Profil
PDO je součástí PHP od verze 5.1, ale to neznamená, že bude na serveru v konfiguraci povoleno. Pokud nemáš možnost konfigurace PHP pomocí vlastního php.ini, tak ho bez spolupráce s adminem hostingu nijak nezprovozníš.
Peett
Profil *
A jak poznam jestli je na serveru povoleno? Jedna se o IC.CZ.
Mastodont
Profil
Na úvodní stránce ic.cz je odkaz na phpinfo a tam je PDO povoleno.
http://baz.ic.cz/phpinfo/phpinfo.php
Davex
Profil
Peett
if (extension_loaded('pdo')) echo "PDO is loaded<br>\n";

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: