Autor Zpráva
Radim24
Profil
Zdravím,
už se cítím fakt trapně, instaluji už třetí verzi mysql, ale všechny mi dělají stejný problém.

Instalace se jakoby povede úspěšně, jenže když spouštím mysqld, vždy program pracuje jakoby s jiným adresářem než do kterého jsem ho nainstaloval.

Poprvé jsem instaloval do adresáře:
C:\server\SERVER_TOOLS\wampserver\bin\mysql\5.1.36
a nyní do:
C:\server\SERVER_TOOLS\phptriad\mysql

V obou případech to pracuje s cestou:
C:\server\SERVER_TOOLS\phptriad\mysql

ale ani v jednom případě to nejde spustit. Vždy říká, že mu nejde najít nějaký soubor v
C:\server\SERVER_TOOLS\phptriad\mysql\data\...

Hledal jsem konfigurační soubory my.ini, hledal jsem v registru po položce "phptriad" a nic jsem nenašel, prostě nechápu proč to odkazuje to toho adresáře.

Stahoval jsem odsud:
http://dev.mysql.com/downloads/
a zkoušel verze:
mysql 4.1.exe
mysql-essential-5.1.39-win32.msi
mysql-essential-5.4.2-beta-win32.msi

s tím, že ta původní ve Wampserveru byla stará a potřeboval jsem upgrade.

Jeslti někdo tušíte problém, prosím poraďte,
díky
Kajman_
Profil *
Hledal jsem konfigurační soubory my.ini

Zkuste ještě pohledat my.cnf, ve windows je často přímo na disku c.
Radim24
Profil
Zkusil jsem odinstalovat Wampserver, znovu nainstlaovat, zase stejný problém. Pak jsem zjistil, že cesta se změnila na documents/.... a pak jsem v tom confu našel položku datadir... takže nevím jakto že mi to předtím nenašlo, ale ten první problém je vyřešen... (správné nastavení umístění adresáře data). Jenže ono to přesto nejde spustit. Možná to nějak souvisí s
default-storage-engine=INNODB
protože v souboru s error logem je toto:


091004 16:25:35 [Note] Plugin 'InnoDB' is disabled.
091004 16:25:35 [Note] Plugin 'FEDERATED' is disabled.
091004 16:25:36 [ERROR] Unknown/unsupported table type: INNODB
091004 16:25:36 [ERROR] Aborting

091004 16:25:36 [Warning] Forcing shutdown of 2 plugins
091004 16:25:36 [Note] wampmysqld: Shutdown complete

091004 16:25:39 [Note] Plugin 'InnoDB' is disabled.
091004 16:25:39 [Note] Plugin 'FEDERATED' is disabled.
091004 16:25:39 [ERROR] Unknown/unsupported table type: INNODB
091004 16:25:39 [ERROR] Aborting

091004 16:25:39 [Warning] Forcing shutdown of 2 plugins
091004 16:25:39 [Note] C:\server\SERVER_TOOLS\wampserver\bin\mysql\mysql5.1.36\bin\mysqld.exe: Shutdown complete
Kajman_
Profil *
Nechápu, jaké souvislosti s tím má winamp. V konfiguračním souboru asi máte špatně nastavené innodb záležitosti.
Radim24
Profil
pardon, mě se to plete, Wampserver. Nastavil jsem

default-storage-engine=MYISAM

a už to jede. Díky za ochotu
Radim24
Profil
ještě dotaz: jak se dá vypnout, abych se nemusel připojovat pomocí
mysql -u root
ale jen
mysql

(jde mi připojit se do mysql konzoly, ale nejde spojit přes PHP)

dík
Kajman_
Profil *
Proč si jako root nevytvoříte uživatele? Nastavte mu heslo a tyto údaje pak použijte v php. Pokud tohle nechcete dělat např. přes příkazovou řádku, zkuste např. mysql administrator z mysql gui tools.
Radim24
Profil
No mě příjde divný, že než jsem začal s tou reinstalací, tak před týdnem a vždy před tím mi to jelo bez -u root tak to pro mě bylo jednoduší, nevytvářet uživatele. Čili nerozumím PROČ to předtím šlo a nyní ne. Snad, že by to bylo tou novou verzí mysql, že by povinně vyžadoval toho roota?
Kajman_
Profil *
Nynější chování je standardní po instalaci. Proč se to předtím chovalo jinak, se ptejte lidí, co chystali tu instalaci.

Pro vývoj je lepší udělat nerootovský účet, který bude mít stejná práva, jako hosting, kde aplikace má běžet.
Radim24
Profil
OK, dík
Radim24
Profil
Zjistil jsem, že problém nebyl v instlací. Jenom já jsem vymazal Databázi Wordpressu. Takže php sice znalo uživatele a heslo, ale databáze neexistovala. Jej to mě nenapadlo.
Toto téma je uzamčeno. Odpověď nelze zaslat.