Autor Zpráva
groom
Profil *
Ahoj, mám dva problémy:
1. problém:
nainstaloval sem novej xampp a ted se mi v control panel ukazuje tohle:
http://2i.cz/a5245872a1
u modules service mám křížky a apache je žluté a dole je něco červené napsané


2.problém:
php se teprv učím, takže netuším kde může být chyba. Podle jedné učebnice sem vytvořil toto
<?php
class parazitFirmy
{
  private $idZamestnance;
  private $barvaKravaty;
  
  function nastavitIdZamestnance ($idZamestnance)
  {
    $this->idZamestnance;
  }

  function ziskatIdZamestnance()
  {
    return $this-> idZamestnance;
  }

  function nastavitBarvuKravaty ($barvaKravaty)
  {
    $this->barvaKravaty = $barvaKravaty;
  }

  function ziskatBarvuKravaty ()
  {
    return $this->barvaKravaty;
  }
}

  $parazit1 = new parazitFirmy();

  $parazit1->nastavitIdZamestnance ("123456");

  $parazit1->nastavitBarvuKravaty ("cervená");

  $parazit2 = clone $parazit1;

  $parazit2->nastavitIdZamestnance ("67890");

  printf("parazit1 id zaměstnance: %b <br />", $parazit1->ziskatIdZamestnance());
  printf("parazit1 barva kravaty: %s <br />", $parazit1->ziskatBarvuKravaty());
  
  printf("parazit2 id zaměstnance: %b <br />", $parazit2->ziskatIdZamestnance());
  printf("parazit2 barva kravaty: %s <br />", $parazit2->ziskatBarvuKravaty());


?>
a na výstupu je:
parazit1 id zaměstnance: 0
parazit1 barva kravaty: cervená
parazit2 id zaměstnance: 0
parazit2 barva kravaty: cervená

Nevíte proč je tam místo čísel jen nuly?
juriad
Profil
k druhému problému:
Řádek 9, chybí ti tam přiřazení
Mike8748
Profil
a k problému číslo jedna... pravděpodobně jsi neodinstaloval předchozí verze apache/mysql a spouští se ti odjinud.
pak když dojde na pokus o spuštění xampp tak to vyhodí uvedené chyby, které znamenají že apache (a mysql) nelze spustit protože již jsou něčím obsazeny porty na kterých to chce fungovat
groom
Profil *
juriad:
Díky, opraveno, už to jde jak má být.


Mike8748:
Já sem dal nastroje odinstalovat programy -> xampp 1.8.0
Nic jiného sem neodinstalovával... co mám teda ještě odisntalovat?
Mike8748
Profil
groom:
je pravděpodobné že se to odinstalovalo špatně, případně máš ještě nejakou předchozí verzi nainstalovanou

otevři si Správce úloh systému windows (zmáčkní Ctrl+Shift+Esc), na záložce Procesy dole klikni že chces zobrazit procesy všech uživatelů, v seznamu potom najdi proces se jménem httpd.exe, klikni pravym, a ve vlastnostech najdeš umístění odkud to bylo spuštěno. z toho poznáš kde je nainstalovaný apache který ti běží a který blokuje tvůj pokus spustit XAMPP.
s mysql bude postup stejný.
groom
Profil *
Mike8748:
Já sem to odinstaloval a když spustím novou instalaci tak mi před tim vyskočí tabulka s:
XAMPP 1.8.1 win3
Important! Because an activated User Account Control (UAC) on your sytem some functions of XAMPP are possibly restricted. With UAC please avoid to install XAMPP to C:\Program Files (x86) (missing write permisssions). Or deactivate UAC with msconfig after this setup.
OK



Mike8748:
Fajn moc díky.... ty procesi sem vbypnul odinstaloval xampp a nainstaloval znovu.... ted uz se mi tam zadné errory neukazujou... díky
groom
Profil *
Mike8748:
Tak ne... po restartu pc to uz nejde...
kdyz zapnu control panel tak se mi tam zobrazi toto:
http://2i.cz/10710d27f4

A kdyz kliknu na Start tak program přestane pracovat a zobrazí se mi tato tabulka:
http://2i.cz/fe9fe3c91a

Ted sem ten xampp znova odisntaloval... máte nekdo nápad co s tim????


Mike8748:
tak sem naisntaloval starší verzi 1.8.0... pri prvnim spustenim mi to slo bez chyb
http://2i.cz/0f9fe3c91a
ale po restartu mi to zobrazuje
http://2i.cz/1e8ef2d80b

Do těch procesu sem se díval a všechno je to umístěné v C://xampp/...

Ale hlavní je že to jde...

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: