Autor Zpráva
Jan Doležal
Profil
Mám projekt, do ktrého chci začlenit náš framework postavený na nette.

Projekt composer.json:
    "require": {
        "php": ">= 5.3.2",
        "janBo/framework": "2.0.*",
        "nette/nette": "2.0.*",

Problém je v tom, že composer stále řve:
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package janBo/framework could not be found in any vers
ion, there may be a typo in the package name.

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your min
imum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> f
or more details.

Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common
 problems.

U frameworku (janBo/framework) jsem už vytvořil branch '2.0.x', tag 'v2.0.x', ale je to stejné. Typo chyba tam není, jelikož když to přepíši na dev, tak to jede.
Dev ale použít kvůli nekompatibilitě nemohu.

Co mám špatně?
Děkuji.
Jan Tvrdík
Profil
Jan Doležal:
A odkud se má janBo/framework stáhnout? Protože není na Packagistu, tak je nutné přidat ručně do composer.json záznam do repositories.


Nepřečetl jsem si to pořádně, takže ještě jinak. Tag 2.0.x je blbost, protože to není validní verze. Zruš ho a přidej místo něj tag 2.0.0 a bude to fungovat.
Jan Doležal
Profil
Jan Tvrdík:
Děkuji,
ty vždy nezklameš ;)

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: