Autor Zpráva
hunter_dave
Profil
Zdravím,

zajímalo by mě, jestli je možné určitému pluginu určit verzi jQuery a zároveň na stránce používat jinou. Napadl mě hack, že by plugin i s jQuery byli v iframu, což by nejspíš fungovalo, ale nepřijde mi to jako vhodné řešení.

Mám dva jQuery pluginy, owlCarousel a nějaký neznámý plugin, který si hraje s pozadím divů, používá starší verzi jQuery (nemyslím si, že bych našel něco podobného) a ty dva se nesnesou.

Neexistuje nějaká jQuery funkce (něco jako jQuery.noConflict), která by konkrétní verzi jQuery použila jen na konkrétní plugin?
joe
Profil
Jde to, ale nebylo by jednodušší vyřešit problém, proč nefunguje ten starší plugin? Zase tolik tam toho asi chybět nebo na úpravu nebude.

Různé verze jde načítat přes funkci noConflict.
<script src="jquery-1.6.0.js"></script>
<script>var jQueryOld = jQuery.noConflict();</script>
<script src="jquery-2.0.0.js"></script>
<script>var jQueryNew = jQuery.noConflict();</script>
hunter_dave
Profil
joe:
Zkoušel jsem to upravovat, ale bohužel se mi to nepodařilo.
Jinak tohle tohle načítání je přesně to co jsem hledal, díky moc.

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: