Autor Zpráva
VčelkaMaja
Profil *
Dobrý den,
učím se s composerem. Na stránkách packagist.org jsem se registroval a vytvořil si zde vlastní balíček. Balíček je navázán na veřejný repozitař, který má v rootu projektu soubor "composer.json". Na stránkách se správou dám update a vše proběhne jak má. Jsou vyplněny všechny (dle dokumentace) potřebné údaje k fungování. Poté si vytvořím prázdnou složku a namapuji si ji v CMD a spustím příkaz "composer require abc/xyz", který vyhodí chybu

[InvalidArgumentException] Could not find package abc/xyz at any version for your minimum-stability (stable). Check the package spelling or your minimum-stability

Soubor composer.json vypadá následovně:
{
    "name": "abc/xyz",
    "description": "Text bla bla bla",
    "license": [
        "GPL-2.0",
        "GPL-3.0"
    ],
    "authors": [
        {
            "name": "Jan Novák",
            "email": "jan@novak.cz",
            "homepage": "https://example.com"    
        }
    ],
    "require": {
    "php": ">=7.1"
    },
    "replace": {
        "abc/xyz": "*"
    },
    "autoload": {
        "classmap": ["src/"],
        "files": ["src/test.php"]
    },
    "minimum-stability": "dev",
    "prefer-stable": true
}

Procházek jsem fora a našel jsem nějaké paramtery, které to mají řešit a to především "minimum-stability": "dev" a "prefer-stable": true, ale problém stále přetrvává. Jak bych jej měl řešit?

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: