Autor Zpráva
acheron
Profil
mam na stranke zopar problemov:
1.blba diakritika , mne to ukazovalo normalne,al ked som si to natiahol u kamosa tak tam boli blbe znaky , tam so skusil dat do tagu head metatag: meta http-equiv="Content-Type" content="text/html; charset=UTF-8" ale nic to nezmenilo , len to ze teraz to uz zobrazuje blbo aj mne (tento metatag mam len v uvodnej stranke,kedze nefunguje inde osm ho nedaval)

2.nejde mi lave menu,mal som spravene menu s premenlivim obrazkom pozadia polozky v menu ale zobrazilo sa mi blbo , tak som skusil urobit ine menu ale to druhe mi zobrazi presne tak isto ako to prve (vid. stranka - ale treba kliknut nejaku polozku z horneho menu aby to bolo vidno)

3.posunutie - v opere (v ktorej som to robil) mi to zobrazi normalne ale v IE a FF je vsetko pod spodnym menu posunute nahor

---pre lepsiu predstavu a pochopenie problemov je asi aj nutne pozriet zdrojak :D

web - www.kaci.wu.cz
Tomáš Hanus
Profil
acheron
1→ Záleží, v čem je ten soubor kódovaný. Pak to kódování můžeš dát do meta tagu. Některé servery (podle nastavení) odesílají stránky v určitém kódování z důvodu souladu.

Buď zdroják nebo stránku (odkaz).
acheron
Profil
nejak nechapem,robim s html len par tyzdnov tak sa nerozumiem do vsetkeho , kde teda mam presne zapisat to kodovanie a co to kodovanie je ?(html a css)?
Manq
Profil
acheron
http://www.jakpsatweb.cz/cestina.html
acheron
Profil
manq to mam uz precitane a keby mi to islo tak sem nepisem ale kedze mam s tim problem tak som tento moj problem zahrnul do tejto temi , na zaciatku html suboru este PRED title mam <b>meta http-equiv="Content-Type" content="text/html; charset=UTF-8"</b> no aj tak mi to nejde , co mam zle
Manq
Profil
acheron
Máš to ve špičatých závorkách?:o)

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
acheron
Profil
OMG ja som dilino , som zabudol prihodit stranku , a teda by ste mi s druhym problemom v ziadnom pripade nemohli poradit asi kedze nemate zdrojak

http://www.kaci.wu.cz/

jj zatvorky tam mam
Tomáš Hanus
Profil
acheron
A v čem to máš kódované?
Pokud text budeš mít v jiném než v UTF-8, meta tag tě již nezachrání
acheron
Profil
skusal som tieto kodovania - iso-8859-2 , windows-1250 , UTF-8 no ziadne mi to nezobrazi spravne , mam taky pocit ze to je pisane vo windows-1250 ale niesom si isty , no ani ten mi to nezobrazi dobre
Tomáš Hanus
Profil
acheron
pokus neco napises v windows-1250 a do meta tagu das windows-1250, zobrazit se to musi spravne. Meta tagem rikas prohlizeci, v jakem kodovani je text, a on prave toto kodovani pouzije. Jeste jednou si prekontroluj, v cem jsi to vlastne napsal. Treba PSPad je dobry ;)
acheron
Profil
v pspade som este nerobil nic , ale tak ... nasiel som to , otvorim si teda moj index.html v pspade hore dam Format a mam tam zaskrtnute Windows (CP1250) , a v heade mam <meta http-equiv="Content-Type" content="text/html; charset=windows-1250"> tak nechapem preco to zobrazuje ako to zobrazuje, ked si pozeral aj natu stranku tak vidis ze tam niesu tie stvorceky ako ma vecsina ludi ktory maju s timto problem ale ...............

ps: nemoze to byt tim ze mam na stranke zmiesanu cestinu so slovencinou ?
etruska
Profil *
a nenačítáš ten obsah náhodou z databáze? já totiž zkoušel použít tu tvoji hlavičku a normálně mi v tom všechno fungovalo... já měl kdysi s databází podobný problém
acheron
Profil
? z akej databaze ?nechapem
Vitec
Profil
1)

V PSPadu zkus nastavit nahoře v záložkách formát --> ISO 8859-2 (nepo windows-1250 proste to kodovani ktere mas nastavene v meta) a znovu uložit.

2)

Moc jsem tomu nevenoval pozornost ale nekde mas v background: url(images/polozka.jpg) a nekde background: url(polozka.jpg)
možna je to tím..

3) Ta mezera tam je mozna kvuli tomu br mezi divy ale nevim nevim mas v tom border:)
acheron
Profil
skusil som to v pspade , len sa mi stvorceky a hatlanina zmenili na otazniky , zmena len na background: url(polozka.jpg) nepomohla (zmenil som to len v polozke halucinogeny) a zrusenie medzeri medzi divmi tiez nepomohlo :( , asi som beznadejny pripad xD
Vitec
Profil
no když už to máš uložené v jinem kodovani tak už se ti to rozhodilo i v kodu mrkni jestli tam nemáš klikiháky. Jestli ne, ale v prohlížeči se to zobrazuje špatně tak fakt nevim kde je problem.

No a ty paddingy co tam máš nastavené mají nějaký význam nebo si je cucáš z prstu?:) Já být tebou tak asi to cele vymazu a zacnu znovu vůbec se v tom nedá orientovat.. a tohle jsem třeba ještě nikdy neviděl:) #nav li#active a
acheron
Profil
konecne sme sa pohli dalej :D , jj bolo to chybne aj v zdrojaku uz to ide OK , a jj viem skoro vsetko v tagu style som len okopiroval z ukazky z inej stranky o webe a menenim tich paddingov a vsetkeho som zistoval co naco sluzi (co sa zmeni) :D tak to mam blbe cele , preto asi aj nejde to menu.....jj asi to prerobim cele ,to posunutie v IE teraz uz asi aj v inich xD je sposobene borderom ???
acheron
Profil
ok , uz len posledny problem - to posunutie , v opere mam OK v FF a IE posunute , ked osam to posunul o 10pix dole (posunute je len lave menu obsah a na pravo odkazy , banner a horne vertikalne menu je OK) tak opera posunutie dole , IE ok a FF posunutie hore , ako urobit aby to bolo vo vsetky prehliadacoch rovnake ?

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: