Autor Zpráva
Icka
Profil *
Ahoj, jdu se zeptat, jestli nekdo nemate zkusenosti s instalaci PHPka ve verzi 4 i 5 na jednom serveru (localhostu Apache ver. 2), zda-li je to vůbec možné.. Mám instalovanou verzi PHP 4, ale potřebova bych mít zároveň i verzi PHP 5.. Zda je to vůbec nějak možné (na OS VISTA) . nebo jestli musim jít alternativní cestou - zrcadlo systému, jinej oddíl s dalšim OS a podobně... Předem děkuji všem za rady a tipy..
Mike8748
Profil
Icka
jde to, proste php5 nainstalujes (rozbalis zip soubor) do jiny slozky nez mas php4. pak se prida konfigurace php5 do souboru httpd.conf

akorat je treba odlisit soubory, podle toho jakym php maji byt zpracovany, treba pomoci pripon (.php pro php5 a .php4)
nebo pomoci bud VirtualHostu nebo Directory kontejneru nastavit pro konkretni slozku ktery php se ma pouzivat (pomoci direktivy AddType)
Icka
Profil *
Ok, modul mám v Apachi načtený, jenom nemohu přijít na to, jak docílím toho, že soubory *.php mě bude zpracovávat PHP4 a soubory *.php5 prozměnu PHP5, nebo případně rozdělit adresářema...
Děkuji
Mastodont
Profil
Icka
Ano, je to možné, XAMPP to umí bez problémů, musíš si ale stáhnout nějakou starší verzi.

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: