Autor Zpráva
Koudis
Profil
Ahoj, do ted jsem používal php 5.2.6 ... kvuli namespace jsem se rozhodl přejít na php 5.3.1 ... stahl jsem si všechny 4 verze z php.net a ani jedna nefunguje ... shodí to celé apache ... nešlo by to nějak opravit abych nemusel reisntalovat celí systém ?
Davex
Profil
Při jaké příležitosti Apache zhavaruje a na jakém operačním systému? Je nějaká chyba v error.log?

Ve Windows bývá obvykle problém s nekompatibilní knihovnou libmysql.dll nebo chybějící knihovnou ntwdblib.dll. Někdy pomůže vypnutí rozšíření mssql v php.ini:
; extension=php_mssql.dll
Koudis
Profil
Davex:
běží to na 32bit win. XP SP3, v extension chyba není , vyzkoušel jsem vypnout všechny ext, apache se ani nespustí ... zobrazí se zpráva o odeslání chyby microsoftu..
(tu ntwdblib.dll mám nakopírovat do hl adresáře php, kdyby se mi podařila sehnat ?)
Davex
Profil
Knihovna ntwdblib.dll se kopíruje do windows\system32.

Porozhlédni se ve vláknech:
spadne apache při connectu na db
Php funguje, MySQL taky, ale dohromady ne.
mysqli na windows 7
Koudis
Profil
Davex:
nakonec jdu z WIN na Debian ..tam to aspon pojede ... dokud neopraví ty binárky pro WIN. zůstanu na UNIXU :)
Carrot
Profil *
Problém bude spíš v tvých rukách, než v binárkách - ty totiž ostatním fungují.

– Stáhls správnou distribuci? (TS, VC6)
– Nemáš někde chybu v konfiguraci? (otestovat httpd.exe /užnevímjakýpřepínač)
– Není někde konflikt/nekompatibilita modulů (spustit http.exe z příkazové řádky)
Koudis
Profil
Carrot:
to ja vim že je to někde u mě :) ... jenom nevím kde ..zkoušel jsem tři různé distrubuce pro windows - apache, všechny spadli s php 5.3.0 .... veeze jsem vyzkoušel všechny pro jistotu / i když u VC9 ,ají napsáno že pro apache nejsou/ ... podle mě jsem si tam někdy něco blbě zkopíroval a ted nevím co :) ... nefunguje XAMPP ani easyPHP, httpd jsem zkoušel spustit z CMD ale jako chybu vypíše jenom číslo chyby...

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: