Autor Zpráva
Guest
Profil *
zdravím,

tak by ma zaujímalo, prečo Debian / Ubuntu používaju stále také staré verzie - Dovecot 1.2 keď už je verzia 2.1* ?

Viem že ide hlavne o stabilitu a o bezpečnost, ale keď vydajú stabilnú verziu, tak prečo sa ochudobniť o rýchlejšiu aplikáciu a nové featury? napr. taký MySQL, v Ubuntu 10.04 je verzia 5.1 ale teraz už bude v 12.04 verzia 5.5.22.

Myslite si, že sa oplatí skompilovať najnovšie verzie? Apache2.4*, Postfix, Dovecot atď? a vynechať baličkóvací systém?

Vďaka za názor.
Davex
Profil
Guest:
prečo sa ochudobniť o rýchlejšiu aplikáciu a nové featury?
Protože nová verze není dostatečně vyzkoušená a může obsahovat skryté chyby, které mohou způsobit značné problémy. Také vznikají drobné nekompatibility mezi verzemi a vzájemná spolupráce se starším systémem nemusí být ideální, protože novější verze může předpokládat i novější verze některých systémových knihoven.

Nikdo ti nebrání zkompilovat a používat novější verze, ale případné problémy si budeš muset vyřešit sám. Já bych takový systém používal maximálně na vývoj nebo testování a nepoužíval jako produkční systém, kde jde především o to, aby to fungovalo.
DJ Miky
Profil
V Debianu existují přímo tři verze: stable, testing a unstable. Můžeš používat unstable, kde budeš mít rychleji nové verze programů. Pak se ale můžou vyskytnout problémy s nekompatibilitou, všelijaké chyby apod.

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: