Autor Zpráva
AdiOverRide
Profil
Zdravím,
prosím Vás mám zakoupený u wedosu VPS a je na něm nainstalován Debian 6.0, Aktuálně pracuje s verzí PHP 5.3 a potřebuji verzi PHP 5.4 můžete mi někdo poradit jak to překonfigurovat?

Děkuji,
A.
Kajman
Profil
AdiOverRide:
Proč nevyužijete podporu hostingu?
AdiOverRide
Profil
Protože Wedos podpora mi řekne že neposkytují uživatelský servis a je to možné řešit 250 Kč za každých započatých 15 minut. A motivace 2. je že bych se rád v tom zorientoval :).
Joker
Profil
AdiOverRide:
Jestli ho ten systém má v repozitáři, mělo by to jít normálně přes aktualizace.
V opačném případě nejdřív přidat repozitář obsahující PHP 5.4 a potom aktualizace.
tpmar
Profil
Joker:
Nemůže se stát, že se tou aktualizací zaktualizuje i něco jiného a rozhaší se tím celý systém?
Enko
Profil
tpmar:
Pravděpodobně ne. Ale udělej si před tímto krokem snapshot a dyžtak se vrátiš zpět do původního stavu. Doporučuji na vlastní VPS přidat ISP Config 3 a přidat PHP Verze například podle tohoto návodu, jak tam přidat další verzi PHP, konrétně zde je návod na PHP 7 a jednoduše můžeš kliknutím myši přepínat v ISP Configu jakou verzi chceš pro jaký web použít. Vždy si ale udělej zálohu stavu před tím, než začneš zasahovat do změn v systému.
Případně pokud chceš jen zvýšit verzi, doporučuji si zjistiti, zda to nepřestanou fungovat nějaké funkce, ale mezi verzí 5.3 a 5.4 se nic zásadního neodehrálo, a pak si najít návod jak to udělat. Stačí googlovat.
tpmar
Profil
Enko:
Ohledně VPS jsem totální začátečník takže mě omluvte, pokud se budu ptát na blbosti.

Ohledně snapshotu, ten se dělá jak? Co jsem tak vyrozumněl tak je to uložení stavu systému ale nevím, jak se to dělá. :/

Ten IPS Config 3 je něco jako administrační rozhraní pro virtuální servery, že? Zvyšování verze PHP se pak dělá klasicky přes následující příkazy?
sudo add-apt-repository ppa:ondrej/php5-oldstable
sudo apt-get update
sudo apt-get install php5
Enko
Profil
tpmar:
Snapshoty se dělají v administrační sekci wedosu -> Serverhosting -> Správa snapshotů (vlevo dole). Ale musíš je mít připlacené v balíčku. V základních balíčcích nejsou. Rozhodně to za to ale stojí, pokud plánuješ nějaké změny na serveru, připlatit si za to, stojí to pár korun měsíčně. Jinak co je je pospsané stručně tady. Pokud tam nemáš ISP Config 3 a nejsi si jistý, že by jsi zvládnul instalci a následné možné zádrhely, tak se na to raději vyprdni a do budoucna nad tím zauvažuj :) Například na Microsoft Azure si můžeš na měsíc zřídit testovací VPSku zdarma a tam si to můžeš zkusit nainstalovat.
Jak se dělá zvyšování verze PHP nevím. Takto jsem to dělal před lety a už nevím. Najdi si ale návod a podle něj to dělej.
tpmar
Profil
Enko:
Ten IPS Config zněl do budoucna sice fajn ale je fakt, že nechci riskovat běh serveru :) jinak díky moc za tipy :)
Pankos
Profil
Můžete zachovat stávající verzi PHP (5.3) a nové verze PHP jen doinstalovat. U každé vytvořené webové stránky si pak můžete vybrat, kterou verzi PHP chcet použít.

Návody jak na to jsou tady:

PHP 5.4.28
www.cms-systemy.cz/ostatni/serverhosting/navody/102-instalace-php-5-4-28-pro-debian-squeeze
PHP 5.5.16
www.cms-systemy.cz/ostatni/serverhosting/navody/125-instalace-php-5-5-16-pro-debian-squeeze
PHP 5.6.0
www.cms-systemy.cz/ostatni/serverhosting/navody/126-instalace-php-5-6-0-pro-debian-squeeze
Davex
Profil
Pankos:
Proč po mě chce ten tvůj web předplatné a bez něj se nedá návod přečíst?

Není chyba doporučovat instalaci PHP na zastaralém a nepodporovaném operačním systému, pro který už od března nevycházejí ani bezpečnostní opravy pro verzi LTS?
Pankos
Profil
Davex:
Na portále CMS systémy je spousta článků, které jsou k dispozici zdarma a některé jeho části jsou uživatelům zobrazeny za malý poplatek.

Chyba to není, jelikož byl vznesen dotaz k této verzi (6) distribuce Debianu a vím, že spousta uživatelů mají od WEDOS tento systém s touto verzí a není v jejich moci provést jeho upgrade na vyšší verzi.

Vaše odpověď


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: