Autor Zpráva
vazo
Profil
Ahoj,
přestalo mi fungovat javascriptové popup okno. Jelikož toto popup okno nefunguje ani na stránkách, kde jsem zdrojový kód objevil , asi nejspíš nebude chyba na mé straně... Mohl by mě pls někdo poradit, kde je chyba a jestli se dá opravit? Případně mám ještě otázečku, je hodně složité, si takovéto popup okno v javascriptu naprogramovat? Myslím, tak naprogramovat, aby nebylo zapotřebí načítání nějakých scriptů od googlu.
Předem díky. ;-)
candiess
Profil
vazo:
, kde je chyba a jestli se dá opravit?
Máte zapnutý JS?

je hodně složité, si takovéto popup okno v javascriptu naprogramovat? Myslím, tak naprogramovat, aby nebylo zapotřebí načítání nějakých scriptů od googlu.
Těmi skripty od google asi myslíte JQuery knihovnu, tato knihovna je obrovským zjednodušením pro JS vývojáře,samozřejmě lze popup naprogramovat bez JQuery, ale trošku víc se u toho zapotíte. Varianta číslo dvě je, že si tu knihovnu JQuery stáhnete a uložíte si ji na svůj server. Tím nebude docházet ke stahování dat od Google.
margin
Profil *
vazo:
přestalo mi fungovat javascriptové popup okno.
Na odkázané stránce jsou asi tři různé ukázky, netuším, co máš na své stránce.
Definuj "funguje" a "nefunguje".

Hádání z kávové sedliny, namísto nejnovější verze jQuery zkus starší, třeba 1.8.3.
vazo
Profil
Je to ten druhý příklad. Javascript mám v prohlížeči zapnutý, pro jistotu jsem to zkoušel v dalších dvou prohlížečích, ale bez úspěchu. Zkrátka dříve se (po kliknutí na odkaz) popup okno "krásně graficky vykreslilo doprostřed stránky s polo průhledným pozadím" a nyní jako by se pouze zobrazila nová stránka. :-/
_es
Profil
vazo:
Asi si ten jQuery plugin nejako prestal „rozumieť“ s novšou verziou jQuery. Aj v chybových konzolách prehliadačov sú chyby. Skús to reklamovať u tvorcu pluginu.
Jan Kupka
Profil
vazo:
Na stránce s ukázkou je Colorbox 1.3.18, tedy verze, která ještě spoléhala na $.browser (viz changelog na https://github.com/jackmoore/colorbox). Jelikož se zároveň do stránky loaduje jQuery 1.9.1, ve kterém podporu pro $.browser odstranili (http://jquery.com/upgrade-guide/1.9/#jquery-browser-removed), nebude to fungovat.

Řešení:
1) Použít novější Colorbox
2) Použít starší jQuery
3) Použít jQuery Migrate

Vaše odpověď

Mohlo by se hodit

Neumíte-li správně určit příčinu chyby, vkládejte odkazy na živé ukázky.
Užíváte-li nějakou cizí knihovnu, ukažte odpovídajícím, kde jste ji vzali.

Užitečné odkazy:

Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: