Autor Zpráva
tappedout.cz
Profil *
Dobrý den,
chtěl bych na své stránky umístit upozornění (klasický odstavec s textem), které se bude zobrazovat pouze uživatelům, kteří mají internetový prohlížeč IE. Bez rozdílu verze. Chtěl bych je upozornit, že aplikace je v některých částech tímto prohlížečem nepodporována. Chtěl bych Vás touto cestou poprosit, zdali neznáte nějaké řešení nebo nápovědu, něco co by mi pomohlo.

Také bych se chtěl omluvit, protože nevím, zdali je řešení pomocí js nebo php.

Děkuji moc všem za radu! :)
juriad
Profil
Proč se chceš chlubit tím, že jsi neschopný udělat web, který funguje všem bez rozdílu?
Myslíš si, že uživatel změní prohlížeč, nebo půjde ke konkurenci, která ho neotravuje upozorněním?

Tato cesta není správná; měl by ses ptát, jak stránku opravit, aby fungovala.
shaggy
Profil
Ako znie otázka, s čím chceš poradiť?
Či je to správny krok? Nie, nie je.
Či to ukazuje na tvoju neschopnosť urobiť stránky správne a poriadne? Áno, ukazuje.

protože nevím, zdali je řešení pomocí js nebo php.
Podľa tohto usudzujem, že stránka nepoužíva žiadnu technológiu/vlastnosť, ktorú by IE nepodporoval, iba to nevieš (nechceš) urobiť tak, aby to fungovalo všade.
Preto by bolo lepšie založiť druhú tému, dať tam odkaz na tvoj web a opýtať sa - čo mám urobiť, aby mi aj v IE fungovalo ...?
weroro
Profil
tappedout.cz:
Užívateľom s vypnutým JS to fungovať nebude. Detekcia IE pomocou JS
margin
Profil *
http://www.zdrojak.cz/zpravicky/nejkratsi-mozna-detekce-ie-ma-pouhych-9-znaku/
Vůbec nemám vyzkoušeno, zda původní nebo maxomálně zkrácená verze detekce fungije v nových verzích IE, tedy IE9 a IE10, dávám to se spíše jako zajímavost.

aplikace je v některých částech tímto prohlížečem nepodporována
Co tak úžasného umí všechny současné prohlížeče a IE to podle tebe neumí a umět nebude, protože hodláš hlášku zobrazovat i v těch verzích IE, které ještě nespatřily svetlo světa?
Joker
Profil
margin:
Ten článek mi ale přijde trochu zmatený a špatně pochopitelný, navíc v ukázkovém kódu chybí právě to klíčové zpětné lomítko.
Pointa je, že JScript v IE neinterpretuje \v jako vertikální mezeru, ale jako písmeno „v“. Takže pak '\v' == 'v' platí jen v IE.
Ale u autora pak někdo poslal ještě kratší verzi: !+"\v1".

Ale na to, co chce tappedout.cz, jakkoliv špatný ten přístup je, by byly nejlepší podmíněné komentáře.
<!--[if IE]>
<p>Neumím udělat stránku tak, aby fungovala ve všech prohlížečích</p>
<![endif]-->
tappedout.cz
Profil *
To je super... Člověk se zeptá na věc, o které nemáte tušení - tím myslím její využití v aplikaci a důvod toho, že není podporována část aplikace a vy místo jednoduché odpovědi, kterou určitě dobře znáte, mě v 5 příspěvcích sprdnete nejen, že tomu nerozumím, že jsem vlastně budiž k ničemu, apod., ale na konci ani neporadíte. Některé věci jako stíny, rámečky, apod. jim prostě fungovat nebudou a pokud app hraje roli ve screenech a grafech, tak je možné, že to nebude tak přesné.

Každopádně díky těm co se snažili. :) Krom toho podmíněné komentáře, již od nové verze 9 a 10 standardně nefungují tak nechápu narážku na to, že to mám pro IE, které nespatřily světlo světa.
Plaváček
Profil
tappedout.cz:

Dodej živý odkaz na problém, který chceš vyřešit. Je pravděpodobné, že pro odstřižení cca 50 % možných návštěvníků není důvod.
tappedout.cz
Profil *
Jedná se o
http://www.jqplot.com/tests/pie-donut-charts.php
margin
Profil *
tappedout.cz:
Krom toho podmíněné komentáře, již od nové verze 9 a 10 standardně nefungují
V IE9 podmíněné komentáře fungují, podpora podmíněných komentářů je odebrána až v IE10.

nechápu narážku na to, že to mám pro IE, které nespatřily světlo světa
Tak zní zadání [#1], „Bez rozdílu verze“, narážku jsem použil proto, že takové zadání nemá smysl.
Chamurappi
Profil
Reaguji na tappedouta.cz:
mě v 5 příspěvcích sprdnete nejen, že tomu nerozumím, že jsem vlastně budiž k ničemu, apod.
Maličko tomu napovídá i jistá osobní historie :-)

Některé věci jako stíny, rámečky, apod. jim prostě fungovat nebudou
Rámečky podporuje Explorer od verze 4. Stíny kolem bloků od verze 9 a kolem textu od verze 10.

pokud app hraje roli ve screenech a grafech, tak je možné, že to nebude tak přesné
Té roli moc nerozumím. Nevím, proč máš podobnou nejistotu jen u Exploreru — pokud stavíš na nějakých křehkých nespolehlivých technologiích, měl bys spíš opodmínkovat hrstku podporovaných prohlížečů, než dělat podmínku na jeden možná nepodporovaný.

Jedná se o www.jqplot.com/tests/pie-donut-charts.php
Tohle mi v Exploreru 7 krásně funguje. Ono tam není nic, co by fungovat nemohlo.
Zatím to vypadá, že největší nekompatibilitou ve tvém díle bude to upozornění, které se chystáš vyrobit.

Vaše odpověď

Mohlo by se hodit

Neumíte-li správně určit příčinu chyby, vkládejte odkazy na živé ukázky.
Užíváte-li nějakou cizí knihovnu, ukažte odpovídajícím, kde jste ji vzali.

Užitečné odkazy:

Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: