Autor Zpráva
Lukas87
Profil
Na úplném začátku každé stránky starutu session, které používám k přihlašování. Doma na localhostu všechno funguje, ale když scripty nahraju na hosting, tak se občas stane že se v IE místo načtené stránky ukáže jen bílá obrazovka. Nedělá to pravidelně, asi to bude souviset s pomalejší odezvou. Pokud smažu řádek session_start(); pak tento problém zmizí. Netušíte někdo v čem by mohl být probém?
johnl
Profil
Lukas87:
Tahle funkce by na to neměla mít vliv, provádí se na serveru né v IE.. Spíš to bude něčím jiným..
Lukas87
Profil
johnl:
nevím čím jiným by to mohlo být. Na jedné stránce co to dělá je například jenom includem vloženo

session_start();
include 'script/func_main.php';
include 'script/config.php';
connect();

a dál to pokračuje statickým html. Navíc pokud session_start smažu tak to dělat přestane.

Moderátor Davex: Vkládej prosím kódy mezi značky [pre] a [/pre] (stačí kliknout na ).
johnl
Profil
Lukas87:
Možná by to mohlo být špatným spojením se serverem když se to stává jen občas.. Ale podle mě to session_start(); nedělá.. Mohl by se k tomu vyjádřit i jiný člen diskuse.. :-)
Davex
Profil
Lukas87:
V jaké verzi Exploreru to zlobí?

V IE6 to zlobilo - IE6 načte stránku až po reloadu, jinak tam není nic.
Lukas87
Profil
Davex:
Díky moc! To je přesně ono. Dělá to jenom v IE6. Stačilo vložit hned po start_session() hlavičku s kodováním.

start_session();
header('Content-Type: text/html; charset=utf-8'); 

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: