Autor Zpráva
Tomashekk
Profil
Má vůbec smysl využívat toto:
if (version_compare(phpversion(), "4.1.0", "<") === true) {
	$_GET = $HTTP_GET_VARS;
	$_POST = $HTTP_POST_VARS;
	$_SERVER = $HTTP_SERVER_VARS;
	$_FILES = $HTTP_POST_FILES;
	$_ENV = $HTTP_ENV_VARS;
	if (isset($HTTP_SESSION_VARS)) $_SESSION = $HTTP_SESSION_VARS;
	if (isset($HTTP_COOKIE_VARS)) $_COOKIE = $HTTP_COOKIE_VARS;
}


if (version_compare(phpversion(), "4.0.4pl1", ">=") === true && ( strstr($_SERVER['HTTP_USER_AGENT'],'compatible') || strstr($_SERVER['HTTP_USER_AGENT'],'Gecko') )) {
	
	if (extension_loaded('zlib')) {
	
		ob_end_clean();

		if (ini_get('zlib.output_compression') != "1") {

			ob_start('ob_gzhandler');

		} else {

			ob_start();

		}

	} else {

		ob_end_clean();
		ob_start();

	}

} elseif (version_compare(phpversion(), "4.0.0", ">=") === true) {

	if (strstr($HTTP_SERVER_VARS['HTTP_ACCEPT_ENCODING'], 'gzip')) {
	
		if (extension_loaded('zlib') && ini_get('zlib.output_compression') == "1") {

			ob_start();
			ob_implicit_flush(0);
			header('Content-Encoding: gzip');

		} else {
		
			
			ob_start();
		
		}

	} else {

		
		ob_start();

	}

}
Davex
Profil
Tomashekk:
PHP 4.1.0 vyšlo před 9 lety, takže to už smysl nemá.

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: