Autor Zpráva
SloWer
Profil *
Zdravím,

už jsem v koncích, obracím se na Vás o pomoc po 2 dnech snahy...

Na notas jsem nainstalovat xampp a nejde mi spustit apache...tak jsem zkusil balicek wamp a ani ten se nespusti...tak jsem zkousel stahnout jen apache, nefunguje...

Na notasu jsem preinstalovaval win...puvodne tam byl xp a Vím ze 100 fungovalo jak wamp tak samostatne apache...
Jenze jsem musel udelat format disku ted jsem znova nainstaloval XP a nejde nic jak je uvedeno víše....
zkousel jsem opet znova preinstalovat win a dal jsem vistu..nepomohlo...
Už jsi fakt nevím rady...

Chyba xampp: kdyz dam start Apache a start mySQL vypise se tohle: Apache started a nic se nedeje, to same s SQL

Chyba wamp: ikonka nenabehna do zelena,

Chyba Apache, ikonta se nespusti do startu ZElene...



pls pomoc
Davex
Profil
SloWer:
nefunguje...
Tipuji, že máš spuštěný Skype, který obsadí port 80. Změň si ho v nastavení na nějaký jiný.
SloWer
Profil *
Davex:
To jsem jeste nestihl nainstalovat, ani ICQ nemam
Davex
Profil
SloWer:
Dodej víc informací. Třeba jakou chybu Apache hlásí po spuštění nebo zaznamená do souboru error.log. Případně jestli nejsou nějaké chyby v systémovém logu.
SloWer
Profil *
Davex:
Spustím XAMPP Control Panel a dam moznost START APACHE,, vypíše se hláška Busy...Apache started [80] a nic se nedeje, nenabehne running...dam znova START a vypise se WARNING: terminating worker thread 0...a zase nic, kdyz dam START MySQL zobrazi se hlaska Busy...ERROR:MySQL service not started [-1]...

Toto byl xampp...

Kdyz nainstaluji wamp, ted jsem zjistil ze nejde vubec , vypise chybu Program Aestan Tray MEnu prestal pracovat...ale to bude asi tim ze tam mam naistalovany xampp...

Vím kde je ten error.log ale kdyz ho otevru nevim co kde znamena a ani nevim kde mam najit systemovy log
Davex
Profil
SloWer:
Busy...Apache started [80]
Apache nebo něco jiného už pravděpodobně na portu 80 běží. Co se stane, když do adresního řádku prohlížeče zadáš http://localhost/?

V souboru error.log bývají chyby s textem [error] na začátku a systémový log je ve Správě počítače - Systémové nástroje - Prohlížeč událostí - Systém.
SloWer
Profil *
Davex:
Tak jsem zkusil nainstalovat zvlášt (apache, php, mysql) vse se povedlo podle tohoto navodu
http://programujte.com/clanek/2007011101-instalace-nejnovejsi-verze-apache-2-0-php-5-2-x-a-mysql-5-0-krok-za-krokem/

Svete div se ale nemuzu nainstalovat Apache do adresare c:/dev/prog/Apache2 protoze nejde, funguje jen C:/dev/Apache, to je zajimave, nechapu....nevadi...

A jeste byl problem ze jsem stahovat verzi PHP Non Thread Safe, musel jsem stahnout jen Thread Safe. Ted uz konecne rozjedu Apache:)

Kdyz ale zadam localhost/
otevru si svuj projekt ktery mám ulozeny v adresari www, ty jednodussi jdou a ty slozitejsi nejdou,
kdyz to nejde tak se zobrazi tabulka Apache
Program Apache HTTP server prestal pracovat, kdyz dam zobrazi podrobnosti

Název události problému: APPCRASH
Název aplikace: httpd.exe
Verze aplikace: 2.2.21.0
Časové razítko aplikace: 4e6a3015
Název chybného modulu: php5ts.dll
Verze chybného modulu: 5.2.17.17
Časové razítko chybného modulu: 4d25fb49
Kód výjimky: c0000005
Posun výjimky: 0000acca
Verze operačního systému: 6.0.6001.2.1.0.768.3
ID národního prostředí: 1029
Další informace 1: bcf8
Další informace 2: 22d6503e4302194edac620a82aed44df
Další informace 3: 7968
Další informace 4: 1f7cf331a31bf43a85c491502953ffc3

Uz jsem zase v koncich, 3 dny to chci rozchodit a nedari se:(
SloWer
Profil *
tak dík...
Krakatoa
Profil
SloWer:
Já teda nevím, ale jestli si dobře vzpomínám, jediný co je potřeba, aby apache + php fungovalo, je aby byly načtené v httpd.conf potřebné soubory, tedy nějak takto:
LoadModule php5_module "c:\server\php\php5apache2_2.dll"
LoadFile "c:\server\php\php5ts.dll"
LoadFile "c:\server\php\libeay32.dll"
LoadFile "c:\server\php\ssleay32.dll"
Máš?
Mastodont
Profil
SloWer:
Zkus si přečíst tohle:
http://www.farinspace.com/php-error-faulting-module-name-php5ts/
slower
Profil *
diky Mastodont, uz vim cim to je, tam se pise typ VC9 je pro IIS a VC6 pro apache, supeeer stahoval jsem spatnou verzi xampu, kdo se v tom ma vyznat...
Krakatoa
Profil
slower:
To je nesmysl, používám verzi PHP VC9 x86 Thread Safe na Apache a to jak v XP tak i Win 7 a bez problému.
Jak jsi mohl stahovat špatnou verzi xampu? To jako sis stáhl nějakou starší? Koukám aktuální používá VC9.

Nemohl by to být spíš problém nepřítomnosti knihoven VC9 v systému? Máš je v systému?
honzisko
Profil
Měl jsem ten samý problém, XAMPP mi také vypisoval BUSY. Vyřešil jsem to zaškrtnutím SVC v xampp control panelu :)

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: