Autor Zpráva
Kane
Profil *
Dobrý den,
mám problém s "rozchozením" uploadu souborů na mým lokálním serveru. Používám IIS5.1 a PHP5.02 (ve WinXP). V php.ini jsem nastavil pro upload adresář takto:
upload_tmp_dir = "F:\inetpub\wwwroot\uploadtemp"
Vždy když vytvořím formulář s prvkem file a dám odeslat, tak se soubor na lok.server nenahraje.
Problém s právy to snad nebude, protože ve stejném adresáři, jako uploadtemp mam i sessiondata a tam to funguje bez problému.
Mohl by mi prosím někdo poradit, jak na to? Děkuji.
Yuhů
Profil
a když se o nenahraje, řekne to něco?
Kane
Profil *
Vůbec nic.
Já osobně si myslím, že chyba bude v IIS. (Asi si zkusím nainstalovat Apache)
Hugo
Profil
A nemas nastavenou nizkou kvotu pro velikost uploadovanych souboru (php.ini)??
Kane
Profil *
Tam mám 2 mega (to jsem neměnil):
upload_max_filesize = 2M
Hugo
Profil
Tak zkus Apache, mam s nim jen dobre zkusenosti :-)
Michalek
Profil
a mas v tagu form neco na zpusob toho
<form type="multipart..."
?
Kane
Profil *
Jo mám. BTW Zkoušel jsem to na jiným serveru a tam to funguje, asi si fakt nainstaluju toho apache.
Kane
Profil *
Tak jsem si nainstaloval Apache 2.0.52, vše nakonfiguroval a upload stále nefunguje. Není náhodou na upload nějaká direktiva v httpd.conf? Alespoň já jsem žádnou nenašel.
Jinak skript je na 100% korektní, protože jsem ho zkoušel na jiném serveru a tam jel. Práva do složky by měly být taky na 100% dobrý (zkoušel jsem to dát i do stejné adresáře jako Sessions). Takže pokud to není serverem, tak to už může být jedině Wokýnkama (mam XPčka).
Tomáš Páral
Profil
Ahoj,

tak s tim jsem mel a vlastne jeste mam asi ten sami problem. Testovano na 4 webech, na 3 upload v poho fungujem, ale ctvrtem ani nahodou, takze nejsi sam :-)

tomas
Toto téma je uzamčeno. Odpověď nelze zaslat.