Autor Zpráva
květka
Profil *
Dobrý den. Chci spustit na localhostu (v xampu) php soubory a píše mi to:
Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0
Nevím co to může bejt, xampp šlape v pohodě. Co bych měla hledat a změnit? Děkuji
Joker
Profil
květka:
Skript používá funkci set_magic_quotes_runtime, která v nových verzích PHP už neexistuje.

Aktualizujte skript, aby magic_quotes nepoužíval. Pokud to není možné, budete muset použít starší verzi PHP (starší než 5.4).
květka
Profil *
Našja jsem toto:
error_reporting (E_ERROR | E_PARSE); include('./data/data.php'); if (ini_get("magic_quotes_sybase")) ini_set("magic_quotes_sybase",0); if (!get_magic_quotes_gpc()) ini_set("magic_quotes_gpc",1); if (!get_magic_quotes_runtime()) set_magic_quotes_runtime(1);

Dá se to nějak poupravit? Děkuji
Joker
Profil
květka:
Podle toho uvedeného skript vyžaduje zapnuté magic_quotes. Což bych považoval za bezpečnostní chybu toho skriptu (magic_quotes mělo automaticky ošetřit řetězce pro uložení do databáze, nicméně snaha o univerzálnost skončila tím, že ošetření řetězců jen přes magic_quotes není bezpečné snad pro žádné použití).

V každém případě, jelikož magic_quotes v nové verzi PHP už neexistuje, úprava skriptu asi nebude tak jednoduchá.
Pokud to je možné, doporučuji skript buď přepracovat, nebo použít nějaký jiný.
Pokud to možné není, tak asi leda použít starší verzi PHP.

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: