Autor Zpráva
Juandev
Profil
Po instalaci nového rozšíření (tvořeno JavaScriptem a PHP souborem) do MediaWiki se mi na místo <memorize /> zobrazuje chyba UNIQ4e5d84764249342b-memorize-00000003-QINU a rozšíření nefunguje. V čem může být chyba? Je to nějaká známá chyba to UNIQ?
Tori
Profil
Juandev:
Je to nějaká známá chyba to UNIQ?
Vypadá to, že na webu MediaWiki ano: http://www.mediawiki.org/wiki/QINU_fix
Juandev
Profil
Aha té jsem si nevšiml. Omlouvám, se ale PHP nerozumím ještě tolik. Když mám v kódu:

function wfMemorize() {
    global $wgParser;

    $wgParser->setHook( 'memorize', 'renderMemorize' );
}

function renderMemorize( $input, $argv, &$parser ) {
    return '<a href="#" onclick="return Mem.start( this )">(memorize)</a>';
}

Jak bych měl ten kód upravit?

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: