Autor Zpráva
Jan Tvrdík
Profil
Protože nemám rád a nevěřím balíčkům jako EasyPHP, Wamp nebo XAMPP, ale hodí se mi pohodlné přepínání verzí PHP, tak jsem si napsal v C# jednoduchý program, který tento problém řeší.

Stáhnout zkompilovanou verzi (64bitová, vyžaduje .NET 4.5, návod na zprovoznění)
Prohlédnout zdrojáky na GitHubu

Tori
Profil
To vypadá moc hezky, taky jsem nad něčím takovým uvažovala. Plánuješ linuxovou verzi?
Jan Tvrdík
Profil
Tori:
Spíš ne. To by se muselo napsat asi úplně jinak. Ta aplikace má vlastně čtyři části - ovládání služby Apache, přehazování symlinku, skládání php.ini a GUI pod notifikační ikonou. Pod mono nefungují ty tři nejpodstatnější z nich.
joe
Profil
Jan Tvrdík:
nemám rád a nevěřím balíčkům jako EasyPHP, Wamp nebo XAMPP
Jsem na tom stejně, jenom se ke mně pořád odněkud dostává, jak jsou tyhle balíčky nejlepší možná věc :-) ale když jsem jsem se je donutil nainstalovat právě kvůli přepínání PHP verzí, nefungovalo to.

PhpVersionSwitcher
Vypadá to jednoduše, jak bude čas určitě to vyzkouším :) Mam teď snad jedinou připomínku, na obrázku bych k těm bílým ikonkám (v trayi) dal taky bílou :-)
Jan Tvrdík
Profil
joe:
bych k těm bílým ikonkám (v trayi) dal taky bílou
Trvalo to rok, ale už to má ikonku, která zapadá do flat designu Windows 8/10.


Po roce jsem vydal další verzi, která řeší především pohodlné přepínání mezi PHP 5 a 7 i v případě, že uživatel používá Apache s modulem pro PHP. Z další novinek stojí za zmínku výrazně lepší podpora pro Nginx a změna konfiguračního formátu na JSON.

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: