Autor Zpráva
d.b.cooper
Profil *
Ahoj všem,

měl bych dělat na dinosaurovy jménem "symfony1" a nedaří se mi zprovoznit úvodní projekt "jobeet", který by měl bý tutorialem.
Vyvýjim na win10 co nejde ještě testuju na win7 a pro příkazovou řádku používám cygwin.
U 3 článku kde se pracuje přes konzoli s doctrine pro vytvoření tabulek mi konzole vrací depreceted chyby a nakonec "segmentation fault" ?
Z nějaké diskuze jsem se dozvěděl jak vypnout deprecated chybový hlášení. Myslel jsem že to může mít někde v kódu vliv (jako třeba výstup před spuštěním session) ale nemá ...

Bylo mi dána rada ať si nainstaluju starou verzi php a starou verzi cygwinu (s poznámkou že stará verze cygwinu se špatně schání ... ano po pár hodinách googlí sem ji nesehnal a vzdal to ... a byly mi dány instalační soubory )

php instalace v balku xampp s pár problémama proběhla a funguje
ale cygwin při instalaci píše že setup.ini nebyl stažen a instalace se zastaví (po vyrání cest k instalaci a (všech) mirroru ) instalačka se jmenovala přímo setup.exe nebo cygwin.exe ... (není tak důležité)

s další diskuze jsem se dozvěděl že se změnil adresář tohoto souboru setup.ini do podadresáře a instalačka musí obsahovat bitovou verzi tedy něco jako setup_64.exe setup_84.exe kde je přímo v instalátoru změněná cesta

jak jsem psal hledání 64bit nebo klidně 32bit staré verze instalačky bylo neúspěšné .. ještě jsem narazil při googlení na možnost stahnutí do aktuální instalačky cygwinu starší verzi php balíku (moc jsem tomu nerozuměl moje EN není nejlepší ale asi se k tomu budu muset vrátit ... )

Chtěl bych se tedy zkušenjších zeptat na pár věcí

1) Jak nainstalovat starší verzi php do cygwinu ?
2) Myslíte že jen verze php můj problém vyřeší ? Nepoužívají se v cygwinu i jiné propojené balíky ? Nedává mi smysl proč by vypnutá hláška depreceted error měla rozbít zpracování kódu ...
3) A poslední věc pouštěli by jste se v dnešní době do studování něčeho tak starého ? :) Mým cílem je nabrat zase nějeká nové zkušenosti. Sice symfony 1 není aktuálně asi nic extra ale když celkově má symfony podíl na trhu myslím že snáz pochopím co a z jakých duůodů je děláno v symfony 2 (v obecném povědomí je že S1 a S2 by mělo být vybráno na základě zadání zkrátka že i S1 má svoje výhody ale možná se pletu )

Díky a omlouvám se za délku textu :)
pcmanik
Profil
d.b.cooper:
Už je Symfony 3, tak nechápem prečo by mal byť nový projekt postavený na naozaj už starom frameworku. Symfony 1 je totiž mŕtve od roku 2012 a 4 roky sú teda naozaj dlhá doba čo sa webu týka.
Naberať skúsenosti z niečoho starého čo sa už nepoužíva nedáva zmysel.

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: