Autor Zpráva
Tomik
Profil
Mám problém,
dosud jsem stránky dělané pomocí PHP dělal v HTML 4.01 a nyní bych rád přešel na XHTML 1.0 (1.1), ale XHTML musí na začátku obsahovat deklaraci použitého xml ("<?xml version="1.0" ..."), pokud ale do souboru neco.php zadám "<?xml version="1.0" ..." php překladač si myslí, že to <?xml znamená začátek php scriptu a samozřejmě to vyhodí chybovou hlášku. Co s tím? Jak lze zkombinovat php a xhtml ? Vadilo by chodně kdybych ptostě tu deklaraci xml přeskočil???

Díky Tomik
thingwath
Profil *
Zcela beztrestně se u XHTML dá XML deklarace vynechat pokud je dokument UTF-8.

Jinak je to nutné oblbnout třeba takhle:

<? print '<?xml version="1.0" ... ?>'; ?>
Leo
Profil
To se resi tak, ze se to nevklada primo ale vypise se to pres echo:

echo '<?xml version="1.0"...';

Leo
Tomik
Profil
To Leo: To je prosté, to mě nenapadlo díky.
mat
Profil
o pár diskuzí níže jsem řešil to samé, viz. předposlední příspěvek této diskuze: http://diskuse.jakpsatweb.cz/index.php?action=vthread&forum=9&topic=15 72 ...:)
Vít Dlouhý
Profil
http://vitdlouhy.cz/clanky/xhtml-parse-error-php.html
Toto téma je uzamčeno. Odpověď nelze zaslat.