Autor Zpráva
llook
Profil
Tak jsem zjistil, že moje PHP (5.1.2-1, systém: Ubuntu 5.10, částečně Debian testing) neobsahuje PDO. Takže jsem to doinstaloval z PECLu:
pecl install pdo

Všechno proběhlo v pohodě, a tak jsem přidal rozšíření do obou konfiguráků (/etc/php5/cli/php.ini i /etc/php5/apache2/php.ini):
extension=pdo.so

Jenže nemám žádný PDO drivery. Zkusil jsem nainstalovat driver pro SQLite:
pecl install PDO_SQLITE

A to mi hlásí tohle:
pear/PDO_SQLITE requires PHP extension "pdo" (version >= 1.0)

No valid packages found
install failed

Pdo rozšíření správné verze (1.0.2) je nainstalovaný, tak co chce? Taky jsem to teď zkusil nainstalovat to bez kontroly závislostí:
pecl install --nodeps PDO_SQLITE

Jenže to skončí chybou při provádění configure skriptu:
configure: error:

You've configured extension pdo_sqlite, which depends on extension pdo,
but you've either not enabled pdo, or have disabled it.

ERROR: `/tmp/tmpKJ4vn9/PDO_SQLITE-1.0/configure' failed


Napadá někoho něco?
llook
Profil
Tak jsem to vyřešil trochu oklikou. Nejdřív jsem zkusil XAMPP pro Linux, ten fachal v pohodě, ale nešlo mi PECL, což se mi nechtělo obětovat. Tak jsem nakonec zvolil instalaci PHP ze zdrojových kódů a všechno jede v pohodě.

Kdoví jaký zběsilosti měli ty Debianí binárky v configure...
Toto téma je uzamčeno. Odpověď nelze zaslat.