Autor Zpráva
gaminn
Profil *
Zdravím,
nainstaloval jsem si Eclipse, bohužel se mi ale nedaří spustit debugger. Vytvořil jsem nový projekt, soubory mohu v Eclipde v pořádku editovat, pokud ale spustím jakoukoliv stránku pomocí tlačítka Debug, stránka se sice v Eclipse zobrazí, ale nikde nevidím žádný výstup z debuggeru (okno pro Debug Output je prázdné). Co dělám špatně?

Ještě dodám, že pokud se přepnu do zobrazení pro debugging, vidím v okně s názvem Debug:
<terminated>.....
- <terminated>Session Terminated
kgb
Profil *
A konzole ti vypise co? (Window->Show View->Console)
gaminn
Profil *
Vůbec nic...
gaminn
Profil *
Žádný debugger jsem v životě nepoužíval, takže možná dělám něco od začátku špatně, nevím, jak to celé funguje.

Stáhnul jsem si Eclipse, otevřel nějaký soubor, cosi nakonfiguroval (zadávala se tam cesta, jakou stránku budu chtít ladit), spustil jsem ladění, v okně se objevil výsledek stránky jako v prohlížeči, ale víc nic se neděje. Vlastně ani nevím, co by se mělo dít, jaký mám očekávat výstup od programu...
gaminn
Profil *
Jinak tento problém řeším ještě na http://forum.builder.cz/read.php?20,1856621 , takže kdyby někdo věděl...
gaminn
Profil *
Nainstaloval jsem si samotný Eclipse + plug-in pro PHP a trochu se mi to podařilo rozchodit - tedy jenom "vzdálené ladění" (remote debugging) a to ještě tak, že mi to je k ničemu. Sice si mohu zadat breakpointy, PHP na nich zastaví, ale nevidím žádné proměnné a jejich hodnoty. Pouze mohu nechat pokračovat v běhu skriptu.

Další taková nepříjemnost je, že když spustím debugging v Eclipse, ještě jsem nespustil stránku v mém prohlížeči (anebo běh skriptu již skončil) a potom chci rozbalit nabídku v okně Debug v Eclipse, vyskočí okno s errorem "An internal error occured during: "Computing hasChildren"". Vím´, že klikat na nabídku v okně Debug ve zmíněncýh případech mi je k ničemu, ale občas mi prostě nedojde, že stránka neběží a tohle okno akorát otravuje.

Další problém je tento - přidal jsem si do nastavení Eclipse další příponu asicovanou s PHP soubory, pokud ale soubor s takovou příponou otevřu, vyskočí mi okno, které mi nabízí tento soubor ke stažení (soubor se zároveň otevře a má správně zvýrazněnou syntaxi). U jiných přípon, které byly defaultně v Eclipse zadané, to nedělá.
Toto téma je uzamčeno. Odpověď nelze zaslat.