Autor Zpráva
Venca
Profil *
Nainstaloval jsem Apache2, PHP 5.0.3.3 a MySQL 4.1. Při použití funkcí jako mysql_connect(), mysql_select_db() atd. se vypíše pouze chybová hláška "Call to undefined function". Neví někdo o co jde? Přitom jiné skripty fungují bez problémů.
Honza Hučín
Profil
PHP 5.0 IMHO nepodporuje MySQL funkce kvůli licenci. Je to divné, ale je to tak. Byl o tom článek myslím na Intervalu, najdi si to.
23k
Profil *
jako fakt? :D tak to nema smysl prechazet na 5tku
llook
Profil
Je fakt, že PHP je šířeno pod jakýmsi derivátem BSD licence, zatímco MySQL je pro nekomerční využití GPL, tedy mnohem restriktivnější.
Takže není možné zahrnout části MySQL přímo do PHP, ale lze je dodatečně přiinstalovat, jde jenom o zkopírování jednoho DLLka (nebo SO v Linuxu) a jeden řádek v php.ini.

Odkaz na ten článek na Intervalu: http://interval.cz/clanek.asp?article=2528
Toto téma je uzamčeno. Odpověď nelze zaslat.