Autor Zpráva
pavelZet
Profil *
jaký operační systém je vhodný pro server obsluhující PHP (LAMP)?

- stačí linux distribuce např. OpenSUSE 10.3?
- bude mít 64bitový OS nějaké nevýhody?
- je vhodné shazovat grafické prostředí?


díky za reakce chlapi.
Mike8748
Profil
zalezi co mas na mysli tim "server"

pokud myslis skutecne server v serverovne nekde umistenej, tak...
- staci distro, podle oblibenosti ( a s kterym umis)
- 64bit... no to zalezi na masine a jejim vykonu. take jestli si prekompilujes LAMP, aby se skutecne vyuzilo to co na tej masine mit budes
- na serveru je graf. prostredi zbytecne, takze neni treba si s nim placat misto. ale obcas by se mohlo hodit (treba pri opravne/upgrade serveru primo na miste), takze nevidim duvod proc nenahodit nejaky light GUI, treba xfce a pod
pavelZet
Profil *
při instalaci 64bit linuxu není obsažený LAMP už předkompilován pro 64bit?
Mike8748
Profil
coz o to mozna je, ale jenom s nejakyma default nastavenima aby behal na kazdym 64bit procesoru
takze to neni uplne idealni
pavelZet
Profil *
jaký nárůst výkonu jde pro PHP očekávat po kompilaci? jedná se o desítky procent, nebo o jednotky?
bukaj
Profil
pavelZet
S linuxem moc asi zkušeností nemáš, že? (Soudím podle toho, co tu píšeš.)

stačí linux distribuce např. OpenSUSE 10.3?
Zrovna OpenSUSE bych moc nedoporučoval, ten je spíše na desktop.

bude mít 64bitový OS nějaké nevýhody?
Všechny problémy, se kterými jsem se setkal na 64bitech se týkaly desktopového využití. Ale stejně jako všechno, má 64bit OS své výhody i nevýhody, ale na serveru bych do něj určitě šel.

je vhodné shazovat grafické prostředí?
Nejvhodnější je grafické prostředí vůbec nemít. Na serveru je zbytečnost.

při instalaci 64bit linuxu není obsažený LAMP už předkompilován pro 64bit?
Je. Pokud ale chceš nějaké speciální volby (distribuční balík prakticky ve všech případech bude mít výchozí volby), musíš samozřejmě zkompilovat. Taky by to s nastavením dobrých flagů měl být rychlejší. Ale pokud nic z toho nepotřebuješ, nedoporučuji kompilovat na "vlastní pěst". Připravuješ se tím o updaty bezpečnostních chyb - musíš si to hlídat sám.

PS. Žádný balík jako LAMP nenajdeš. LAMP je akronym pro Linux Apache MySQL PHP (nebo Perl, Python). Linux máš, takže akorát doinstalováváš Apache, MySQL a PHP.

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: