Autor Zpráva
alteaffe
Profil *
Zdravim mam problem s formularem celou stranku mam v utf-8 , kdyz ulozim z textoveho pole text obsahujici apostrofy "" tak se mi to ulozi do databaze jak ma , na strance se mi to take zobrazi ale kdyz dam editovat ten text tak v tom formulari je pouze text a od mista kde byli apostrofy uz zadnej text neni priklad:
toto je "priklad" textu Ale zobrazi se jen toto je a ten "priklad textu uz tam neni.
Cim to je ? V databazi je ten text celej .
Mam to takto
<input type="text" value="<? $db['text']; ?>">
Měsíček
Profil
Je možný, že to nepovolí dvojté uvozovky " "" " takže dej value='<?php $db["text"];?>">
alteaffe
Profil *
Mesicek je to stejny , nefunguje to
alteaffe
Profil *
zajimave ale je ze kdyz si necham zobrazit zdrojovy kod stranky tak tam ten celej text ve value je
Měsíček
Profil
To začíná být zajímavý .. pošleš odkaz na tu stránku?
alteaffe
Profil *
jo mnel jsi pravdu dal jsem tam jen klasicky ' ' nevim jak se jim rika a ted to funguje
alteaffe
Profil *
value = 'text'
alteaffe
Profil *
ale mozna ze je chyba v tom ze kdyz ukladam text tak jde prvne prez ocistku stripslashes a trim a to prave odstrani \ \
protoze ten text by se ulozil takto text \"text v apostrofach "\ text a tudis by to nedelalo pak problem .
Měsíček
Profil
no tak hlavně, že už to funguje :)
nightfish
Profil
<input type="text" value="<? $db['text']; ?>">
mimochodem tohle má dělat co? chybí tam buď echo, nebo zkrácený zápis (<?php=$db['text'];?>)

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: