Autor Zpráva
pako_02
Profil
Nainstaloval som uspesne Apache aj PHP. Otestujem instalaciu pomocou phpinfo() ale namiesto vystupu mi vypise len kod. Skusal som aj iny funkciu napr <?echo Date("G:i")?> a taksito mi skript nespracovalo, iba vypisalo kod. PLS poradte mi co mam robit.
nightfish
Profil
Nainstaloval som uspesne Apache aj PHP. Otestujem instalaciu pomocou phpinfo() ale namiesto vystupu mi vypise len kod.
takže instalace apache a php úspěšně neproběhla...
máš v httpd.conf řádek s LoadModule, a AddType?
máš v PATH soubor php5ts.dll?
píše něco apache při spuštění apache.exe (při zastavené službě Apache)?
pako_02
Profil
do httpd.conf som dopisal tieto 3 riadky:
#LoadModule php5_module c:/php5/php5apache2.dll
#AddType application/x-httpd-php.php
#PHPIniDir "C:\php5"

takisto som spravil to s tym Path (tam som dospisoval c:\php5) a Apache funguje ako ma nevypisuje ziadne podozrive hlasky. Mimochodom pri insatlacii som postupoval podla knihy. V skripre chybu nemam.
peta
Profil
pako_02
google.com wamp server
odinstaluj, co mas a zkus nainstalovat toto.

<? a <?php je dost podstatny rozdil. Zkousel jsi i ten druhy zapis?
Poustis to jako localhost:// nebo zkousis soubor otvirat pres windowsove okenka?
Localhost funguje, pokus je apache spusteny. To se da zjistit v procesech (ctrl+rshift+esc)
pako_02
Profil
zapis <? a <?php som skusal = rovnaky vysledok. Pustam to cez http://localhost/phpinfo.php a ano Apache bol a je spusteny. Ten wamp skusim vecer.
pako_02
Profil
No nainstaloval som ten wamp a slape to! Diki moc. Ale je dost mozne ze by slapalo aj to moje, je dost mozne ze mi Centrum zabezpeceni blokovalo Apache pretoze po insatalacii wampu sa ma spytalo ze ci ho ma "stale" blokovat.
srigi
Profil
do httpd.conf som dopisal tieto 3 riadky:
#LoadModule php5_module c:/php5/php5apache2.dll
#AddType application/x-httpd-php.php
#PHPIniDir "C:\php5"



Heh, vies o tom, ze tie riadky su zakomentovane a teda neucinne. Stacilo by iba zmazat tie mriezky na zaciatku a asi by sa to rozbehlo.
pako_02
Profil
ked som ich dal bez mriezok tak mi nefungoval Apache. Som ich tam potom dopisal a fakcil. V tej mojej knihe to bolo tiez bez mriezok.
srigi
Profil
ked som ich dal bez mriezok tak mi nefungoval Apache.

Toz si mal chybu v php.ini. Ked si tie direktivy (riadky) zakomentoval, vyradil si cely PHP engine.
¨pako_02
Profil *
Ok diki vam vsatkym za rady, halvne je ze mi to fakci. Ked pojdem najblizsie instalovat zvlast Apache a PHP hadam budem mudrejsi.
srigi
Profil
Nerad to pisem, ale dobre navody ako zprevadzkovat AMP server pod widlami ma Hulan. Staci zajst na jeho stranky a dat si vyhladat 'apache'. Okrem ineho tam najdes aj navod ako skonfigurvat virtualne servery.

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: