Autor Zpráva
teapack
Profil
Zdravím,
mám problém s třídou ZipArchive:
$zip = new ZipArchive;

vypíše Class 'ZipArchive' not found

Vygooglil jsem akorát to, že tohle je podporováno v PHP 5.2 a vyšší (mám PHP 5.2.1) a že musí být odkomentovaný extension v php.ini (php_zip.dll - splňuji).

Tak v čem je problém?
Alphard
Profil
restartoval jste po odkomentování server?
častá chyba je také úprava špatného php.ini
teapack
Profil
restartoval jste po odkomentování server?
častá chyba je také úprava špatného php.ini


Ano, restartoval. Dokonce několikrát.
Edituji php.ini, na které odkazuje phpinfo() (Configuration File (php.ini) Path).
V konfiguraci PHP extenzí je php_zip zaškrtnutý (=aktivní).

Není potřeba ještě doinstalovat jinou extenzi pro PHP 5?
___max
Profil *
měl jsem stejný problém a pomohlo toto:
zprvu jsem dohrál dll knihovnu jen "ručně" do adresáře ext a nic
tak jsem znovu spustil instalák phpka a ve výběru jsem zvolil pouze instalaci extension/zip..tím se mi tam extension doinstalovala a po restartu phpka se zip rozchodil..

Vaše odpověď

Mohlo by se hodit


Prosím používejte diakritiku a interpunkci.

Ochrana proti spamu. Napište prosím číslo dvě-sta čtyřicet-sedm: